Support » Plugin: Facebook for WooCommerce » “missing required information from developer”

  • Resolved gbruzzo

    (@gbruzzo)


    Dear Sirs

    We recently installed the Facebook for Woocommerce plugin on our production site.

    The first connection went well. We set up catalogue and shop.

    We then started having some issues with our catalogue (synchronisation issues). We therefore decided to delete the following from FB: shop, the catalogue (first deactivated then deleted), all users/partners from the business manager. Concurrently we had deactivated the connection on the WordPress/Woocommerce Admin.

    When we now try to reconnect via the plugin, we initally see a message saying:

    “You’ve previously linked WooCommerce Extension V2 to Facebook
    Would you like to continue with your previous settings?” with two choices

    a. edit settings b. Continue as <FB username>

    selecting both options results though in the following response:

    “Missing required information from developer
    Some of the information required to set up the connection correctly is missing. Please contact the developer for more information.”

    We are stuck in this loop.

    Could you please advise as to what steps we can undertake to reconnect our store with our FB page again?

    Thank you in advance

    Giacomo Bruzzo

    • This topic was modified 1 year, 10 months ago by gbruzzo.
Viewing 4 replies - 1 through 4 (of 4 total)
  • @gbruzzo this is under discussione here https://wordpress.org/support/topic/missing-required-information-from-developer/

    Unfortunately, suggested solution did not work for me but, maybe, it works for you

    Thread Starter gbruzzo

    (@gbruzzo)

    Hi there

    thank you for your response.

    We just tried that method – all seems to go well, until we input the final ‘OK’.

    Then we get a (Woocommerce) notice saying something went wrong and to try again.

    We truly would appreciate @skyverge intervention on this matter.

    Thanks in any case

    Plugin Support simonskyverge

    (@simonskyverge)

    Hey folks!

    Thanks so much for the community involvement here, it’s great to see everyone working together to try to resolve these issues! As @lorex75 mentioned, if you’re specifically seeing the “Developer Information Required” error when connecting, I would recommend following the linked topic, as we will be updating that with further information as we hear it. It also suggests to reach out to us with additional information that Facebook could use to help troubleshoot the problem, which would be a great help!

    If you’re having an issue with events being recorded in your theme, please do raise a new topic for us to help. Using the old version of the plugin, compared with the new version, could be different as we added Server to Server event recording with v2. Though please be aware, we’ll want to take a look at the issue with v2 active in case we need to apply any fixes to the plugin code. This may mean waiting for the developer information issue to be solved first.

    Thanks all!

    Simon.

    Plugin Support simonskyverge

    (@simonskyverge)

    Hey folks!

    As per the related thread: https://wordpress.org/support/topic/missing-required-information-from-developer/page/2/

    Facebook has let us know they’ve released a change in the connection process that should have resolved this issue. We’ve had quite a few merchants respond with positive news, and they’ve been able to connect and continue as normal now.

    If you haven’t yet had a chance to try the connection again, please do! Any further queries or issue, please raise a new topic so that we can look at them individually.

    For now, I’ll close this based on the results we’ve had so far. Thanks again for reporting this to us!

    Cheers,

    Simon.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘“missing required information from developer”’ is closed to new replies.