Support » Fixing WordPress » Missing number after URL

  • Resolved Tessila

    (@tessila)


    In the link I need help with, I have three categories: “Landscapes”, “Flowers”, and “Other”, and they each have their own photographs for sale. I made each photograph available for sale, then I found out that all the products in “Landscapes” were all mixed up. I found the problem was that they didn’t have a number at the end of each of their URLs to differentiate them from each other. There are four product names that each of my photographs I’m selling have: Regular Prints, Canvas Prints, Poster Prints, and Greeting Cards, but they all have different parents, so everything should be in order like my “Flowers” and “Other” categories are, but they aren’t.

    So I deleted all my products and everything from my “Landscapes” category to start over from scratch, but when I created the first one, it had the same problem. No number at the end of the URL.

    If I didn’t make any sense, you can see with these links:
    http://tessilamcleanphotography.blackcoffeeranch.com/product/canvas-prints-44/
    http://tessilamcleanphotography.blackcoffeeranch.com/product/canvas-prints-63/
    They have the same name, but have a number at the end of the URL to keep them separated.

    What is keeping my products in “Landscapes” from having numbers at the end of the URLs, but not in my other categories? How can I fix it?

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Sunny Kumar

    (@5unnykum4r)

    So basically you want to list them in Category wise section?

    for example: example.com/product/category_name/product-name-ID

    You can do it by changing Permalink Setting in WP Admin Panel.

    WP Admin>Setting>Permalink and Change Permalink as you want.

    You can check out this guide on Permalink structures

    Tessila

    (@tessila)

    Yes, I think that’s what I want. I think it worked now, since I made a new product. Thanks a lot for your help! I really appreciate it.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.