Support » Fixing WordPress » Missing my “add new” plugin button

  • Resolved GlobetrotterElisa

    (@globetrotterelisa)


    Hello!

    I have updated my wordpress, and after I did this, my “Add new” plugin button is missing. I only see the list of my already installed plugins and are not able to add new plugins. What is wrong?

Viewing 15 replies - 1 through 15 (of 31 total)
  • Hello,

    The Add New button should display under the menu options as well as on the main plugin page. If you are not seeing that, you may have an issue with other plugins or the theme affecting the core of WP.

    To check the theme, simply set your theme to the default one and check to see if the Add New button reappears. If so, then you will need to either change themes altogether or switch to the default them when you want to add a new plugin. If the button still does not appear, you will want to check your plugins.

    To test this, turn off all plugins and see if the button appears. If so, then turn them on one by one to determine which one is affecting the WP. If the button still does not appear after turning off all the plugins, you may want to reinstall WordPress. If this is a brand new installation, simply delete the old one and then reinstall. If you have a lot of content, you will simply want to reinstall the core files on your account so you do not lose any data.

    i hope this helps

    Thank you… I have now tried everything you suggested. Still not working… 🙁

    I had the same problem. Very annoying. I solved it by clicking on to the “My Sites” button right at the top of the page. This gave me two options, Namely “Network Admin” and my webpage title. By hovering or clicking on the “Network Admin” part – a menu dropped down which included ‘plugins’. I clicked on this – and it changed the Dashboard. When I clicked on Plugins a menu dropped down which included “Add New” and “Editor”. Problem solved. I hope this helps.

    John

    Hi Elisa,

    The same happens to me. I’ve tried to deactivate all my plugins and change themes, but nothing works. Till I came to this tip:
    When I build my website, for the security I’ve given all my files and maps limited permissions. On top of it, I’d added a little code in my wp-config.php:

    define(‘DISALLOW_FILE_EDIT’,true); //edits
    define(‘DISALLOW_FILE_MODS’,true); //updates

    Probably this cause conflict with the Plugin Add new and Delete button. I’ve change the code to:

    define(‘DISALLOW_FILE_EDIT’,true); //edits
    define(‘DISALLOW_FILE_MODS’,false); //updates

    This add the Add new and Delete button back to the Plugin section, but not the Editor option. But this works for me for now. I hope this will solve you problem too. Good luck!

    Meme

    • This reply was modified 1 year, 6 months ago by fm_ade.

    Same issue here – looked at my backup WP-CONFIG file an the define(‘DISALLOW_FILE_MODS’,false); was not in the file.

    Why would WP add this to our file? Who can answer this?

    Hello everybody!

    Thank you so much for taking your time on this.

    I did have to change some codes in the wp-config.php. I do not remember exactly what I dit (the technical part is not my thing…), but at the end I ended up fixing it.

    Very annoying this problem!!!

    My blog is after 3 weeks with several problems, up and going again!

    Thank you all!

    I don’t know what is causing this. I’m *guessing* for me it’s BoldGrid.
    I note that on other WP installations, I also see Add New in the left hand bar (Hover over Plugins > Add New), but it’s missing from this single installation. Odd.

    I’m doing a workaround on the issue for now by replacing “plugins.php” at the end of my URL with “plugin-install.php”

    Ex: Change https://example.com/wp-admin/network/plugins.php to https://example.com/wp-admin/network/plugin-install.php

    guilloome

    (@guilloome)

    Hello Everyone.

    Had the same issues for few minutes on one of my websites… In case you are in site/multise, the add button is only on the master admin website, not on website.

    mailmyap

    (@mailmyap)

    The same:

    The issue is when you add // define(‘DISALLOW_FILE_MODS’,true); in wp-config.php

    I just discovered my fresh install isn’t allowing plugin uploads either….not to mentioned the new wordpress visual editor is awful. What the heck is happening to WP?! I also made the change many of you are suggesting but it didn’t fix anything…Guess I just have to upload through cpanel, what a pain….

    I found it.
    Please get into your wordpress dashboard.
    On the top-left point your cursor to My Sites > Network Admin > Plugin > Add New.

    I think WordPress just want us to manage the plugin installed for all of our wordpress web altogether and make the arrangement centralized in Network Admin menu.

    Hope this will help. Thanks.

    Also having this issue. I’ve tried uninstalling/ reinstalling our plugins without result.

    Moving on to themes, but I’m new to WordPress and have a Q: If I change to a new theme and then want to revert back to our current theme, will I have to redo all of our customization? They were done by a number of vendors over the past few years and no one knows any details about them, so I”m hoping to avoid if possible before adjusting the template.

    Thanks!
    Rose

    I think there are two conversations here – one referring to multisite admins, and one about single site admins.

    I don’t have multisite, so I can’t speak to that – anyone with a single site looking for answers can ignore anyone who talks about “My Sites” menus and the like.

    As for us single users, @fm_ade had the right answer (at least for me).

    I went into my hosting account and opened wp-config.php in the editor. Right at the top were the includes – mine didn’t exactly match hers, but my site was originally built in 2007, so I imagine there have been changes over the years that were not applied to my updates.

    I saw the define(‘DISALLOW_FILE_MODS’,true); statement in the config file and I just changed it to false. I saved the file, refreshed my plug-ins page in WordPress, and the install button appeared.

    I hope this helps clarify for others.

    Ernie

    Missing add new plugin – missing and new themes. What I did to resolve this different strange issue. Hovered over Dashboard – clicked upgrade network – clicked upgrade network again. Solved the issue. I can add new themes and plugins. If anyone is still having issues with it hope this helps.

    Hi

    i have a website on word press i want to make some changes in my about us page
    but pages and add plugins option is missing on my admin dashboard.Is there any
    setting in C-panel that need to change or there is any other problem?
    Thanks

    • This reply was modified 10 months, 1 week ago by shadab Awan.
Viewing 15 replies - 1 through 15 (of 31 total)
  • You must be logged in to reply to this topic.