Support » Plugin: BuddyPress Registration Options » Missing Mail type filter in pending user mail

  • Resolved Drivingralle

    (@drivingralle)


    Hey!

    Today I was setting up a site and added HTML to the pending user mail that showed up in the mail program.

    I debugged the plugin and found that within bp_registration_options_send_pending_user_email() in line 592 the filter bp_registration_options_set_content_type to change the mail type is missing. The filter is removed but never added.

    Greetings
    derRALF

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    Hey @drivingralle

    It may be why it’s failing, but I know I see an add_filter() for that same one, all the way up on line 61.

    May need to be brought over to right before we send the email.

    Hey!

    Within bp_registration_options_send_admin_email() the filter is also added and removed separately, therefore I guess it would be required for the user facing mail too.

    I hotfixt the plugin in my project and now all my mails are clean.

    Greetings
    derRALF

    Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    @drivingralle I’d be curious to see what you have, and working. Would be willing to review and potentially merge in to the plugin itself.

    Just submitted a PR on Github.

    Greetings
    derRALF

    Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    Received and will review soon.

    Marking thread as resolved in the meantime.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Missing Mail type filter in pending user mail’ is closed to new replies.