Support » Fixing WordPress » Missing “logged-in admin-bar” on homepage

  • I’ve updated all plugins and themes, cleared cache and cookies, tried THREE different browsers on two different computers, the problem is still present.

    After upgrading to 4.7.4 (I believe), my homepage and posts made after the update are missing the admin bar upon viewing. Posts made on and before April 23 (the day I upgraded) still display the admin bar, posts made after it do not display the admin bar.

    The good news: I disabled a BUNCH of plug-ins just now, and one of them must have caused the problem with the ‘posts’ code because now I can make posts and have the admin bar displayed after making the post. The older posts still don’t display the admin bar.

    However, the damage has been done to the homepage despite the plugin being turned off. I had a look at the code, and the difference between the pages with and without the admin bar comes in the following lines:

    With admin bar: <body class=”post-template-default single single-post postid-xxxx single-format-standard logged-in admin-bar custom-background customize-support”>

    Without admin bar: <body class=”post-template-default single single-post postid-xxxx single-format-standard custom-background customize-support”>

    On the homepage, the default homepage template is displayed, but right after “page-id” there is no code for “logged in admin-bar” to display, hence it’s not displayed.

    I have MINIMAL coding experience, so I’m at a loss as to where I need to adjust the code to call the functions for “logged-in admin-bar” to be displayed for the homepage.

    The “Show Toolbar when viewing site” user option IS checked, by the way.

    I’ve also tried changing themes, and have the same problems.

    Any and all help is appreciated

    Edit: I tried creating a new homepage with the same template and selected the new homepage as the default homepage. When you view the new page as a page, you can see the admin toolbar. When you view it as the homepage, you can’t see the admin toolbar.

    Edit 2: This is weird, and possibly relevant. If I post a new post and “view” it from the editing menu, it will be displayed with the admin bar and the title will be displayed in the “latest posts” sidebar menu. BUT if I go to the homepage, the new post will not show up on the homepage, nor will it show up in the “latest posts” sidebar menu at all. So basically, the homepage is stuck NOT displaying any new posts even though they have been posted. This just started after I tried creating a new default homepage page.

    • This topic was modified 2 years, 5 months ago by  danburkhead. Reason: clarification
    • This topic was modified 2 years, 5 months ago by  danburkhead.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Karan NA Gupta

    (@nuancedesignstudio)

    Hi,

    Are you using a caching plugin like WP Super Cache or W3 Total Cache?

    Karan

    No caching plugins that I’m aware of.

    Karan NA Gupta

    (@nuancedesignstudio)

    Can you try viewing your site using Private Browsing or Incognito window? It seems to me like a caching or a CDN issue.

    So I reinstalled everything, including the theme.

    I’ve viewed with with my phone and several different browsers.

    Google Chrome: Old content is there. When I try to make changes to the homepage (customize it after the fresh install) through Chrome, nothing appears to be saved. If I make a new post, the latest post is NOT displayed, nor is it part of the “latest posts” widget feed on the homepage sidebar. If I go into the admin area via the admin login, then view the post, it shows up and appears on the “latest posts” widget feed on the sidebar.

    Microsoft Edge: Customized changes appear. Latests posts are NOT displayed, nor are they part of the latest posts feed on the homepage.

    Phone: Same as edge. I can see changes, but the latest posts are not posted on the homepage or on the homepage’s feed.

    Here’s what the homepage looks like: (no background, no new feed)

    Homepage

    Here’s what a new post looks like: (background is there, I just cropped it out)

    post page

    • This reply was modified 2 years, 5 months ago by  danburkhead.

    If I go private browsing/incognito on Chrome, the problems are still there (homepage still not changed after customization, new posts not showing up but old posts are still there)

    If you want to see the site and maybe do some sleuthing . . .

    Homepage: http://www.quakesfan.com

    The latest post that is not being displayed: http://www.quakesfan.com/2017/05/02/technical-problems/

    • This reply was modified 2 years, 5 months ago by  danburkhead.
    Karan NA Gupta

    (@nuancedesignstudio)

    Hi,

    It’s a strange issue. The last post is of May 2 – http://www.quakesfan.com/2017/

    Can you try this – Deactivate ALL plugins – and then check. If it didn’t work create a post (with all plugins still disabled) and check. If it still didn’t work, use the default twenty seventeen theme and check.

    In case it worked at any stage activate one plugin at at time to find the problematic plugin.

    It sounds like a conflict with your theme and/or a plugin.

    I deactivated ALL plugins, yet they still are working on the homepage.

    If I go to any other pages or posts, they are deactivated.

    ???

    Karan NA Gupta

    (@nuancedesignstudio)

    I am not able to figure out what could be wrong. But looks like you’re using the Sporty theme, and you could also try the theme’s support https://wordpress.org/support/theme/sporty

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Missing “logged-in admin-bar” on homepage’ is closed to new replies.