Support » Plugin: Loco Translate » Missing languages

  • Resolved kureman

    (@kureman)


    Hello,

    Recently, I added a new plugin to my site. It appeared in the plugin list of Loco Translate but my site language was missing.

    So I added a custom one and I observed that the texts I translated into this custom language weren’t translated on my site.

    Finally I looked for the .po and .mo files of the plugin on https://translate.wordpress.org/projects/wp-plugins and I uploaded them in public_html/wp-content/languages/plugins/.

    Now, in Loco Translate, there are 2 languages for this plugin: one in custom folder, one in system folder. The custom translation now is ok.
    (A weird thing is when I pressed on sync for the system language, it changed a bit, the progression bar is not completely green, there is some red… and one text is preceded by a yellow cloud).. I don’t understand why since I have just uploaded the last translation version… if someone has an explanation..)

    I see now that I have an other plugin without system folder whereas I can find the system files on https://translate.wordpress.org/projects/wp-plugins

    Sorry if I am missing something but why Loco Translate has not added the po and mo files of these plugins in the system folder?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Tim W

    (@timwhitlock)

    why Loco Translate has not added the po and mo files of these plugins in the system folder

    Loco Translate doesn’t automatically add any files anywhere. It is a file editor and writes files where you ask it.

    I suggest you read some of the manual and beginner’s guides to understand how it works, and also what the sync function does.

    Thread Starter kureman

    (@kureman)

    Hello @timwhitlock , thank you for your answer.

    Indeed, manual helped me to understand some points.

    However, I still don’t understand why when I installed (for example):
    – “Loco Translate” there is only my site language in system folder.
    – “Code Snippets” there are more than 10 different languages in the folder author, and my site language in system.
    – when In installed “WOOF – WooCommerce Products Filter” there are Polish/Spanish (Spain)/English (USA) in author folder but not my site language in system.

    I may missed something in the documentation, could you help me understand?

    Plugin Author Tim W

    (@timwhitlock)

    Files in the author folder are shipped with the plug-in. The author put them there.

    If something is not installed in the system folder, probably there are no translations available from WordPress.

    Thread Starter kureman

    (@kureman)

    Ok, I got it thanks.
    BTW, could I delete the unused files in the author folder or it’s not recommended?

    If something is not installed in the system folder, probably there are no translations available from WordPress.

    Sorry, I am not sure to understand yet…
    I have an example with the plugin Zahls. After it’s installation, there was no file for French in the system folder but I can find something here:
    https://translate.wordpress.org/locale/fr/default/wp-plugins/zahls-ch-payment-gateway/
    I have observed that with WOOF too.

    Plugin Author Tim W

    (@timwhitlock)

    It looks like it is only 24% translated, so probably not complete enough to be published. This is a WordPress matter and not related to my plugin.

    There is little point deleting anything from within plugin and theme folders. They will just reappear when you update your system.

    Thread Starter kureman

    (@kureman)

    Ok! Everything is clear, thank you for your answers!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.