Support » Installing WordPress » Missing items in Admin after upgrading 2.9.2 -> 3.0.1

  • Resolved phoenixreguy


    Gak. Upgraded (manually) from 2.9.2 to 3.0.1. Upgrade seemed to go fine, but I’m missing three items from my admin menu:

    Under Appearance there are no Menu or Widgets buttons
    Under Profile (which on my other 3.0.1 install is labeled “Users”) there is no Users button.

    If I try to go directly to the URL, and /widgets.php I get a screen with nothing but “You do not have sufficient permissions to access this page.”

    Going to I get “Cheatin’ uh?”

    Searching far and wide in these great forums, those point to WP not thinking I’m an Administrator. But a check in the database shows the correct info for admin access. I also tried setting up another user account with admin level and still can’t see the Menus, Widgets or Users options.

    I’ve tried:
    Redownloading 3.0.1 files and re-installing (full manual install, with all plugins disabled and deleting/replacing files not just over-writing)

    Using Twenty-Ten rather than Thesis for the theme

    But these menus items are always missing.

    It’s acting like the upgrade only partially updated the DB — if that’s possible.

    Everything else appears to be fine. Blog looks fine, no issues commenting and all other admin functions appear to be funsctional

    Host is Rackspace Cloud.
    Site is
    PHP memory_limit = 64M
    PHP v 5.2.13

    Any suggestions? If it matters, auto upgrade ALWAYS fails, so that’s why I do it manually.


Viewing 11 replies - 1 through 11 (of 11 total)
  • Just wondering if anyone had ANY thoughts or ideas on this problem…

    Hey phoenixreguy. I’m having the EXACT same problem on two different 3.0.1 sites. One site was was updated from within the Admin area automatically, and the other I updated manually. Both sites reside on different hosts.

    But the similarity is that I cannot access the exact same admin areas as you:
    widgets.php &

    One site is live while the other is merely a test site. So on the test version, I have been doing some experiments, such as disabling all plugins, deleting all plugins, checking the htaccess file and permissions, resetting permalinks, and finally (and since it’s a test site I can take this risk) poring through the database itself and deleting un-needed tables and modifying meta values.

    So far, nothing has worked.

    I am still being denied access to some of my own site’s admin pages. It’s bizarre.

    But I’ll keep working on it. Tomorrow I’ll attempt a fresh install of 3.0.1 in a new location and import one of these two site’s databases in an attempt to isolate the problem.

    If you can fix it in the meantime, or any one else out there knows what is the problem with 3.0.1, please add your input!

    ywammer – I’ve messed around in the database as much as I’m comfortable with on a live site, and gotten nowhere.

    Any luck with a fresh install in a new location?

    It is bizarre… and annoying.



    same her, and with the same items missing.

    I installed a fresh wp and copied only the database. And I god the problem again on this one..

    Ok guys. I’ve fixed it. Sorta. Here’s what I did:

    The error lies somewhere within the wp_options table within the WordPress database. Here’s my (functional, but admittedly lame) way of “fixing” the problem:

    1. Backup the entire WordPress database EXCEPT FOR the wp-options table,
    2. DELETE the database and reinstall WordPress (this creates a new database),
    3. DELETE all the tables in the new database EXCEPT FOR wp_options.

    Now, with this new error-free wp_options table all alone in your newly created database…

    4. IMPORT the old backed up database (that one with no wp_options table in it).
    5. Review all site settings, re-activate all plugins. And now you should be set.

    The only glaring downside to this fix is the fact that you will need to re-activate all plugins and re-do all site settings. And you’re site will be down for a few hours. This took me upwards of an hour to do on my site.

    The upside is that it has fixed the missing users, widgets, and menus pages in the Admin section.

    Let me know if this works for you. Or you’ve found a better way to do it. 🙂



    Thanks for this!! It worked but it take some time, jeah…

    If you know how, you can fix the database-stuff at your local installation (MAMP), that’s less stress then a long downtime.

    And remember to take care of all settings (also from the plugins) before you take the last step – changing the database! 🙂

    Good luck, and maybe there is a better way.

    ywamer – your fix worked for me. It was a PITA, but it worked. THANK YOU!!!

    Glad to hear. PITA indeed. Makes me afraid of the impending 3.0.2 upgrade. Let’s hope it was only a 2.9 > 3.0.1 conversion issue, and not a bug in the upgrade process itself.

    I had the same issue, but resolved it without re-installing WP.

    I was using the User Capability Manager plugin, and I had to revert to the default WP roles.

    Also, I went through the wp_options table inside phpMyAdmin and found a few errors that I corrected.

    I also had to logout/login to get the Users/Widgets/Menu links to show up.

    Hope this helps someone.

    @ywamer, That is not a fix, it is a workaround through partial re-installation. PITA? that is an understatement. I don’t even have the time required to do that for all the blogs i updated. Which is about 4 of them, and these are work related not personal.

    @nickd32, I would love to see an example.
    a side-by-side of a ROW with an error and one without.

    And if possible a any SQL you used to fix them.

    good news, I was able to fix this problem/error.
    Now the User menu is visible again,

    The error is located in,

    select option_value from wp_options where option_name = 'wp_user_roles';

    I was able to get the VALUE from a fresh 3.2.1 installation, the correct value is,

    Once I replaced the VALUE with the fresh install value, the error was gone. No PITA re-installation/workarounds.

    My SQL is shotty at best, I am a linux systems admin, not a DBA. So i ended up just using a quick web script to do this SET.

    I absolutly hate the over engineered phpmyadmin, So I found the minimal Adminer. Only one small .php file, no installation process. Upload -> Utilize -> Remove.

    I hope i could help anyone. BTW, i was coming from a very old installation. If that makes any difference.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Missing items in Admin after upgrading 2.9.2 -> 3.0.1’ is closed to new replies.