Support » Plugin: WooCommerce Stripe Payment Gateway » Missing inputs in CC form

  • Resolved cohemelaqk

    (@cohemelaqk)


    hello,

    I have a problem on my website. I have installed your plugin but in some languages, I missing the inputs in the CC form to fill with the number, expiry date and ccv.

    Someone else has the same problem?

    Thank you

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi,

    Possibly the same issue here? Just installed the Woo Stripe plugin for the first time. The form fields for cc data are not showing, Stripe integration is throwing some errors in the console, and the formatting of the available payment methods seems to be off (see https://snag.gy/bH2Y8r.jpg).

    stripe.min.js:1 Uncaught TypeError: Cannot read property 'elements' of undefined
        at HTMLDocument.<anonymous> (stripe.min.js:1)
        at i (jquery.js:2)
        at Object.fireWith [as resolveWith] (jquery.js:2)
        at Function.ready (jquery.js:2)
        at HTMLDocument.J (jquery.js:2)
    (anonymous) @ stripe.min.js:1
    i @ jquery.js:2
    fireWith @ jquery.js:2
    ready @ jquery.js:2
    J @ jquery.js:2
    ?add-to-cart=1508&attribute_level=Vriend&variation_id=1511:1 Unchecked runtime.lastError: The message port closed before a response was received.
    jquery.js:4 POST https://cultuurfondsrijkvannijmegen.nl/wp-admin/admin-ajax.php 400 (Bad Request)
    send @ jquery.js:4
    ajax @ jquery.js:4
    (anonymous) @ idcommerce-min.js:255
    i @ jquery.js:2
    fireWith @ jquery.js:2
    ready @ jquery.js:2
    J @ jquery.js:2
    stripe-payment-request.min.js:1 Uncaught TypeError: Cannot read property 'paymentRequest' of undefined
        at Object.startPaymentRequest (stripe-payment-request.min.js:1)
        at Object.success (stripe-payment-request.min.js:1)
        at i (jquery.js:2)
        at Object.fireWith [as resolveWith] (jquery.js:2)
        at x (jquery.js:4)
        at XMLHttpRequest.c (jquery.js:4)
    startPaymentRequest @ stripe-payment-request.min.js:1
    success @ stripe-payment-request.min.js:1
    i @ jquery.js:2
    fireWith @ jquery.js:2
    x @ jquery.js:4
    c @ jquery.js:4
    XMLHttpRequest.send (async)
    send @ jquery.js:4
    ajax @ jquery.js:4
    getCartDetails @ stripe-payment-request.min.js:1
    init @ stripe-payment-request.min.js:1
    (anonymous) @ stripe-payment-request.min.js:1
    i @ jquery.js:2
    fireWith @ jquery.js:2
    ready @ jquery.js:2
    J @ jquery.js:2
    stripe-payment-request.min.js:1 Uncaught TypeError: Cannot read property 'paymentRequest' of undefined
        at Object.startPaymentRequest (stripe-payment-request.min.js:1)
        at Object.success (stripe-payment-request.min.js:1)
        at i (jquery.js:2)
        at Object.fireWith [as resolveWith] (jquery.js:2)
        at x (jquery.js:4)
        at XMLHttpRequest.c (jquery.js:4)
    Plugin Support Thomas Shellberg

    (@shellbeezy)

    Automattic Happiness Engineer

    Hi @cohemelaqk,

    I have installed your plugin but in some languages, I missing the inputs in the CC form to fill with the number, expiry date and ccv.

    Can you provide a URL to see this issue on your website?

    @lijndiensten – it’s a good idea to create your own threads for issues unless you’re positive they’re the same – it will avoid confusion and cluttering up threads. Your issue sounds like a plugin/theme conflict, do you get these same errors if you test with just WooCommerce and Stripe plugins enabled, along with a default theme like Storefront/2019?

    (Jup, sorry, a plugin conflict after all. Thank Thomas)

    Plugin Support Thomas Shellberg

    (@shellbeezy)

    Automattic Happiness Engineer

    Hey @cohemelaqk,

    It looks to me like your /it/checkout/ page is not loading the JavaScript from Stripe needed to process payments. You can use the Debugger tab of your browser’s Developer Tools to debug further. Perhaps a plugin(like an optimization plugin) or a caching plugin is omitting the JavaScript files needed to process the credit card through Stripe.

    Thread Starter cohemelaqk

    (@cohemelaqk)

    Thank you!

    I have solved the problem :))

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Missing inputs in CC form’ is closed to new replies.