WP Post to PDF Enhanced
[resolved] missing images on private site (4 posts)

  1. ajg-cal
    Posted 1 year ago #

    Hi Lewis

    Possible bug I need to test tonight but might be a particular to my setup!

    I was messing around with a "private" site using the Members plugin (enabling the option "Redirect all logged-out users to the login page ... "

    I noticed that all the images in the PDFs generated from private site were missing.

    If I used relative URLs for the images then they appeared in the PDF. I'm using this plugin here as a workaround.

    (src="/wp-content/uploads/2013/12/lightning.jpg" instead of src="http://gunyon.co.uk/wp-content/uploads/2013/12/lightning.jpg"

    Your plugin is not alone in with this issue... mpdf also has a problem with missing images. So it's maybe the site's fault rather than the plugin.

    I have some more info tonight! this is just a note



  2. Lewis Rosenthal
    Plugin Author

    Posted 1 year ago #

    I can see how this might happen, though I'm hard pressed to think of a good way around it for now. I think the Relative Image URLs plugin you referenced is probably the best way to deal with the situation.

    Looking forward to hearing whatever else you discover in your testing, and I'll see about how I might address the situation more effectively.

    Cheers, and thanks!


  3. Lewis Rosenthal
    Plugin Author

    Posted 1 year ago #

    Hi, Alex...

    I'm inclined to mark this as resolved, in the sense that we have a workaround using the additional plugin (though I should add something to the FAQ, in case I haven't already).

    Let me know your thoughts when you have a moment.



  4. ajg-cal
    Posted 1 year ago #

    Hi Lewis yep that's fine thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Post to PDF Enhanced
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic