• Resolved parakeet

    (@parakeet)


    Does not include two of the three icons I needed to use:

    far fa-grin-hearts

    fas fa-box-open

    The other is fas fa-magic

    FontAwesome is already enqueued in to my site header…

    <link rel=’stylesheet’ id=’FontAwesome-css’ href=’https://use.fontawesome.com/releases/v5.2.0/css/all.css&#8217; type=’text/css’ media=’all’ />

    All three fonts work fine when used in manual code.

    Don’t see the need to allow the plugin to enqueue FA, as I prefer to let it be enqueued by my theme.

    What should I do?

    Thanks.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Matt Keys

    (@mattkeys)

    I see all of the icons you mentioned in my test environment using 3.0.0 beta 2. I see you’ve already commented on this thread with a similar question:

    https://wordpress.org/support/topic/some-fonts-not-available/

    Hopefully your problem will be resolved the same way?

    Thanks, but I’m not sure I understand the answer…

    I have to wait for a new version to come out before I can see the icons in the back-end; is that right?

    Plugin Author Matt Keys

    (@mattkeys)

    In the case of that other thread, the person didn’t know about the settings area, and the plugin was configured to use v4.x fonts, not v5.x fonts.

    If you are in a similar situation all you should need to do is go to the settings area and tell the plugin to us FontAwesome 5.x fonts.

    But, I’m afraid I don’t understand…

    There is no Settings area I can find for this plugin.
    Are you saying I need a new, Beta version in order to get a Settings area?
    And it’s that Settings area I can use to flip this from FontAwesome 4 to 5, which should show all the icons?

    If so, how do I get the Beta?

    Thanks.

    Plugin Author Matt Keys

    (@mattkeys)

    FontAwesome 5 fonts are only available in the beta of this plugin, you can read more about it including instructions for downloading the beta here:

    https://wordpress.org/support/topic/v3-0-0-beta2-with-fontawesome-pro-icons/

    Oooh, I see.
    I never knew that version selector was there.

    Okay, that fixes it – both threads resolved. Thanks. This is great.

    BTW, I am running some hefty xdebug and, on the Settings page, the checkbox for “Enable Pro Icons?” is throwing quite a lot of “Notice”.

    Resolved…

    Plugin Author Matt Keys

    (@mattkeys)

    Glad it is sorted out now.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Missing icons’ is closed to new replies.