Support » Fixing WordPress » Missing Homepage

  • Resolved otis30223

    (@otis30223)


    I manage this site for our HOA. For a few weeks I keep getting a 404 error on our homepage. The rest of the site functions normally only the homepage has an issue. I’m running 5.1.1 and php 7. I’ve searched forums from a dozen different sites, reset permalinks, checked .htaccess files. Performed site restores and no luck. Short of deleting the site and starting fresh, which would require considerable time, does anybody have a suggestion on how to resolve this issue. It appears to be a redirect issue but why it’s doing it l have no clue. I’ve deactivated every plugin and used the reinstall from the dashboard with no success. I also note the the preview function in the editor does not appear to work as well as live preview in the theme selector. Any help or insight your could provide will be greatly appreciated.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Yes, if you type it in that way it will appear. But if you go into the theme and set it as homepage it does show when you type the standard address.

    It looks like you just have a blank index page in your site setup somewhere, which has the following meta tag in it:
    <META http-equiv=”refresh” content=”0;URL=http://rghoa.net/wordpress”>

    Find where that tag is, remove it, set the proper home page in your WP theme, and see if that helps. My wild guess would be that you have a blank index.php file in your site’s root, that is meant to redirect the URL to where you were setting up WordPress originally and then after publishing, didn’t remove the file, so it’s still redirecting.

    • This reply was modified 3 months, 2 weeks ago by  Amanda K..

    I believe you are on the right track, but when I remove the line <META http-equiv=”refresh” content=”0;URL=http://rghoa.net/wordpress”> and save the homepage settings I get a blank page. Any suggestions, I have looked though all the index files I could find. I will state that there is a folder marked redirect in the root directory. I inherited this site from another webmaster and cannot attest to what was done prior to my getting the site. It worked well until my host upgraded PHP to version 7.

    I have resolved the error, in the root folder was a file named index.html, this is the one containing the line <META http-equiv=”refresh” content=”0;URL=http://rghoa.net/wordpress”>. I saw in another post that this file should not exist and could create issues. So i deleted that file and the redirect folder which contained another copy of the index.html file. once deleted the site now loads properly, I hope this helps someone else as it gave me fits.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.