Support » Plugin: Post Grid » Missing GRID SETTINGS when Filters turned on

  • Hi there, I’ve just installed the pro version of your plugin so that I could use the category filters, which is great.

    One thing I noticed when changing the settings is that when I toggle the FILTERABLE option at the top ON, then the GRID SETTINGS menu (where you can set the width of the grid items) seems to disappear.

    See screenshots:

    Normal view: https://imgur.com/Oes4F9m

    Filter Toggle on view: https://imgur.com/vLF0Uc7

    I tested this in several different different grids, all with the same result.

    If I toggle the filter on while I’m on the grid settings tab, I can still access and edit the settings, but if I click to a different menu option, there’s no way to get back to the grid settings without toggling back to NORMAL first. Hope this makes sense, thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author PickPlugins

    (@pickplugins)

    Thanks for your post, I understand the issue, will fix and update plugin soon.

    Thread Starter sarahsas

    (@sarahsas)

    Hi @pickplugins just wondering on the status of this? I saw you issued an update, but it doesn’t seem to have fixed this issue for me? I still can’t access the GRID SETTINGS menu while FILTERABLE is toggled on…

    Also, after the most recent update, I can now see a very ugly “Post Grid lazy load” text appearing before all the grids load – this is happening on ALL of my sites that I have run the most recent update on, but here is one example – https://sarahshahinian.com/news/

    See screenshot: https://imgur.com/ikRHQVQ

    Please advise?

    Plugin Author PickPlugins

    (@pickplugins)

    Please update version 2.1.0 of free plugin, hope this will be fixed the issue.

    REgards

    Thread Starter sarahsas

    (@sarahsas)

    Thank you, yes the missing menu item has been resolved (GRID SETTINGS) but the “Post Grid Lazy Load” text is still appearing? as per my screenshot here: https://imgur.com/ikRHQVQ

    Plugin Author PickPlugins

    (@pickplugins)

    Please add a lazy load image or disable lazy load.

    hope you understand.

    Regards

    Thread Starter sarahsas

    (@sarahsas)

    Ah I see, thank you for explaining. I was confused because I’ve been using this plugin for several years now and that broken image/description text has never appeared before, even with lazy-load enabled. It only began appearing across all of my sites after the most recent update, so I thought perhaps it was something new.

    Thanks!

    Thread Starter sarahsas

    (@sarahsas)

    Hello again, a few things:

    1. This issue with the GRID SETTINGS not appearing is still happening in the PRO version, but only on the initial page load of each post grid settings. If I toggle NORMAL GRID on and then toggle back to FILTERABLE, then the GRID SETTINGS menu appears and stays, which is an improvement. But if I refresh the page, it disappears again. Not a huge issue, but wanted to point it out…

    2. On this page: https://new.ausdancevic.org.au/whats-on/ – if I try to filter by the Category labelled 2021 – nothing happens? I’ve removed and re-added the category, checked the category settings are all correct as well. There should be 2 posts in this category, but it seems like the click action isn’t working at all here? Any thoughts?

    3. At the moment, with pagination on the filterable grids (same page as example here: https://new.ausdancevic.org.au/whats-on/) From the ALL tab (which on this page is PROJECTS & EVENTS) if I navigate to the 2nd page and then click on any of the filters, it displays most of them as empty? Is there no way to enable the filters to filter ALL pages at the same time, with pagination applying just to each category?

    Hope this makes sense, it’s tricky to verbalize my issue in #3, let me know if you need screenshots, or if it makes sense? thanks!

    Thread Starter sarahsas

    (@sarahsas)

    For anyone else wondering…

    Answer to #3 – PAGINATION with FILTERABLE GRIDS as follows:

    Under QUERY POST, max # of posts per page need to be set to -1.

    Then use the settings under FILTERABLE tab to set the actual # of posts per page.

    Then under pagination, choose FILTERABLE PAGINATION.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Missing GRID SETTINGS when Filters turned on’ is closed to new replies.