WordPress.org

Forums

Dynamic Widgets
[resolved] Missing green ticks (5 posts)

  1. soultga
    Member
    Posted 1 year ago #

    Thank you for creating such a useful plugin! I use it extensively at http://www.fashionandstyledirectory.co.uk/ to display different banners on different URLs.

    It has worked great to date, and just today I set up a new homepage banner. This evening, however, I'm finding that when I click through to edit the dynamic settings for a previously setup widget, the green tick next to 'URL' is gone and my exceptions listed in the box under the 'Show widget at this URL?' heading are all missing. The settings are still working, though - all the banners are displayed on the right pages as before - I just can't see the details to edit them any more.

    Similarly, if I create a brand new text widget and give it dynamic settings, these are successfully applied to the site but have no tick and are not visible for me to edit once I save them. In the main interface, however, WordPress knows that I have 'Options set for URL and Directory' - I just can't see those options once I click through the 'Dynamic' link.

    I haven't installed any new plugins since this afternoon, and I've tried uninstalling and reinstalling Dynamic Widgets without it making any difference. I've also deactivated all other plugins, with no difference.

    I'm a bit stumped! Any suggestions? Basically, I can currently create new dynamic widgets, but can't edit any that already exist without re-entering all the options from scratch.

    https://wordpress.org/plugins/dynamic-widgets/

  2. Qurl
    Member
    Plugin Author

    Posted 1 year ago #

    Well, I have successfully reproduced your issue. So, it's a bug. And I have also found already what the problem is. My apologies, this is a stupid mistake I made there. I'm gonna fix this asap.

  3. soultga
    Member
    Posted 1 year ago #

    OK, thanks - that's great!

    I'm glad I was able to explain it clearly enough for it to make sense - and that it's nothing I've broken ;)

  4. Qurl
    Member
    Plugin Author

    Posted 1 year ago #

    Small update already, I've pushed a fix to the development version.

  5. soultga
    Member
    Posted 1 year ago #

    Yes, that works now! Thank you :D

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Dynamic Widgets
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic