Support » Plugin: Acunetix Secure WordPress » Missing file in 2.0.2

  • Resolved CyberOto



    Just updated and got this

    Warning: require_once(inc/json.php) [function.require-once]: failed to open stream: No such file or directory in /public_html/wp-content/plugins/secure-wordpress/secure-wordpress.php on line 105

    You cannot get to admin also, so you have to delete the plugin via FTP.


Viewing 8 replies - 1 through 8 (of 8 total)
  • Quick workaround is to download 2.0.1 and 2.0.2 and copy files from 2.0.2 archive over the 2.0.1 then upload the new merged folder and activate the plugin.

    Still got some issues like:

    Can't connect to server [110].
    If the problem persists please continue at Website Defender.

    but that I can live on =]


    Same issues here. 2.0.2 is broken

    For a quick solution, enter by ftp and rename the secure-wordpress folder to another name (for example:aaa_secure-wordpress).

    That doesn’t solve the problem, plugin still broken, but your site is online again until Website Defender could repair the plugin.

    The new version is missing the directories css, img, inc, js, and languages plus all the files in those directories. These files and directories gets messed up by the automatic update functionality when you go from 2.0.1 to 2.0.2.

    I fixed the problem by downloading the 2.0.1 and 2.0.2 versions of secure-wordpress and manually FTP’ing 2.0.1 first and then 2.0.2 so that the new files overwrote the 2.0.1 files but the directories remained intact.

    Works fine for me now with the missing directories recovered.

    Well, it appears that I have the same problem but I tried deleting and uploading the previous version and it is still giving me the same message. I think it may have something to do with the fatal error related to some google plugin associated but i am not sure. Any ideas?

    Warning: require_once(inc/json.php) [function.require-once]: failed to open stream: No such file or directory in /home/globalp/public_html/blog/wp-content/plugins/secure-wordpress/secure-wordpress.php on line 105

    Fatal error: require_once() [function.require]: Failed opening required ‘inc/json.php’ (include_path=’/home/globalp/public_html/blog/wp-content/plugins/official-google-site-verification-plugin/external/php-client::.:/usr/lib/php:/usr/local/lib/php’) in /home/globalp/public_html/blog/wp-content/plugins/secure-wordpress/secure-wordpress.php on line 105


    First of all we are really sorry for the inconvenience caused with this plugin update.

    We already uploaded a fixed version of the plugin which can be downloaded from:

    If you have problems accessing your blog because of the plugin update, simply login via FTP or your host’s control panel and delete the plugin directory. The default plugin directory can be found in /wp-content/plugins/ WordPress sub directory.

    While hoping you find this plugin useful, feel free to post any queries or suggestions you might have on the WebsiteDefender forums;

    Looking forward to hearing from you.

    Robert Abela
    Technical Manager – WebsiteDefender

    I downloaded this new version per the link above. First I deleted the secure wordpress from my plugin and then uploaded this 2.0.3 version. I’m still getting the same error message. Is there something else I need to do to get my site working again? I’m using Firefox.

    Hi Majmar21

    Try to clear browser cache.


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Missing file in 2.0.2’ is closed to new replies.