Support » Plugin: Schema & Structured Data for WP & AMP » Missing field “mainEntity”

  • Resolved LauraHartwigDesign

    (@laurahartwigdesign)


    I received a message from Google Search Console saying FAQ issues were detected on my site. Here is what it said:

    Top Errors
    
    Errors can prevent your page or feature from appearing in Search results. The following errors were found on your site:
    
    Missing field "mainEntity"
    
    We recommend that you fix these issues when possible to enable the best experience and coverage in Google Search.

    I’m not sure why it is saying this now.
    When I checked my console, it said the error was here:
    <!– Schema & Structured Data For WP v1.9.86 – –>
    <script type=”application/ld+json” class=”saswp-schema-markup-output”>
    [{“@context”:”https:\/\/schema.org”,”@type”:”FAQPage”,”@id”:”https:\/\/www.majorhomes.net\/awnings\/fixed-awnings\/#FAQPage”},

    Can you tell me how to fix this? Thank you!

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Sanjeev Kumar

    (@sanjeevsetu)

    Have you updated to our latest v1.9.86.1 ?

    Hi Sanjeev,

    Yes, it happened after your last update! We don’t have FAQ pages on our website but I have also received a letter from Google about the FAQ issues with most of our posts!
    Should I return to the previous version to fix it?

    Just an example:
    https://jmp.sh/YNi1w2o

    • This reply was modified 1 month, 1 week ago by ArtFl.
    Thread Starter LauraHartwigDesign

    (@laurahartwigdesign)

    I’m at Version 1.9.86.1. Thanks.

    Can confirm that the issue was fixed in the latest update on our site. We did have to clear our site’s entire cache to perform the new validation.

    Thank you for your input about the cache, nephilim777, while the plugin support keeps silent.

    I have the same problem. Also, I received alerts with “Invalid object type for field “author”” in Woocommerce products.

    Update: Forget it. The update fixed it.

    • This reply was modified 1 month, 1 week ago by rairt.
    Plugin Support Sanjeev Kumar

    (@sanjeevsetu)

    Both the issue related to author and FAQ have been fixed in latest version. Please update the same.

    If you are still facing issues. Please create a new thread.

    ArtFl

    (@artfl)

    Sanjeev,
    isn’t it possible for your team to test the new versions before you release them?

    It’s the same all the time. You release the new version, people update to it, their posts become invalid, then you release the patch but it takes a long time till Google considers your posts valid again.

    Thread Starter LauraHartwigDesign

    (@laurahartwigdesign)

    @artfl The version I’m using is the free version. I really appreciate them making the plugin available to me. They replied to my support question and fixed the problem quickly. I see there is a premium version available with priority support, but I’m happy with the support I received for paying absolutely nothing.

    Thank you Sanjeev!

    ArtFl

    (@artfl)

    @laurahartwigdesign, I’m not saying that their support is bad. They are very nice people, and they also helped me a few times to fix the problem. I’m also grateful for this free plugin which is, actually, good.

    I’m only saying that these problems usually appear after the updates. I think it’s better to prevent the problems in advance than work hard to fix them later. In my case, I installed the 1.9.86 version too fast on October 18, and until now I can’t get validation from Google for 109 posts.
    Next time I’ll wait for 3-4 days before updating.

    • This reply was modified 1 month ago by ArtFl.
Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.