Support » Plugin: Breadcrumb NavXT » Missing field “itemListElement”

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author John Havlik

    (@mtekk)

    So, from what I see right now on the linked page, there is the wrapper for the breadcrumb trail, but there are no breadcrumbs in the trail. This is likely to cause problems with the search console. If you want the breadcrumb to be there, make sure the Home Template (unlinked) is set to:

    <span property="itemListElement" typeof="ListItem">
        <span property="name">Home</span>
        <meta property="url" content="%link%">
        <meta property="position" content="%position%">
    </span>

    If you don’t want the breadcrumb trail on the home page, you should use something like the following as your calling code:

    <?php if(function_exists('bcn_display') && !is_front_page()): ?>
    <div class="breadcrumbs" typeof="BreadcrumbList" vocab="https://schema.org/">
    <?php bcn_display(); ?>
    </div>
    <?php endif;?>
    Thread Starter Afterimage Designs

    (@afterimagedesigns)

    Hi,

    I already added the code – https://prnt.sc/1172ut, yesterday, on the plugin settings.
    May I asked where should I add the PHP code you provided?

    Please advise, thank you!

    Thread Starter Afterimage Designs

    (@afterimagedesigns)

    Hello!

    The above issue was now gone. But a new error was detected – https://prnt.sc/11ahd0e. I already added property=”name” to the templates but it still doesn’t being validated.

    Can you advise?
    Thank you!!

    Plugin Author John Havlik

    (@mtekk)

    So, the PHP code I posted would go in your theme, or child theme, wherever the call to bcn_display() is located.

    Regardless, based on what the breadcrumb trail is currently generating, the structured data testing tool seems to be happy with the markup. However, it looks like your Home Template is wrong. You should use something like:

    `<span property=”itemListElement” typeof=”ListItem”><span property=”name”>Home</span><meta property=”position” content=”%position%”></span>

    At least, that is based off of one page I checked. For some reason the blog section seems to be using completely different settings.

    • This reply was modified 3 weeks, 1 day ago by John Havlik.
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.