Support » Plugin: AMP » Missing extensions (youtube, twitter etc.)

  • wturrell

    (@wturrell)


    Hello.

    I’m looking at the plugin source code for the oembed handlers – what specifically does it do to activate the javascript extensions for videos, tweets etc and are there any obvious hooks in a site’s theme/plugins that could prevent it from working?

    I’ve a site which is returning errors such as:

    – The tag ‘amp-twitter’ requires including the ‘amp-twitter’ extension JavaScript.
    – The tag ‘amp-youtube’ requires including the ‘amp-youtube’ extension JavaScript.

    (The <script> tags are indeed completely absent, so it’s not the protocol-relative URL issue you’ve pointed out to people in other posts.)

    example AMP page with video:
    https://www.markpack.org.uk/150573/why-conservatives-lost-steve-parker/amp/

    example AMP page with embedded tweets:
    https://www.markpack.org.uk/137315/lib-dem-european-referendum-campaign-twitter-account/amp/

    Looking through the client’s theme, there’s code that hooks into embed_oembed_html and wraps the HTML it’s passed in a <figure> tag, but doesn’t otherwise alter it.

    AMP version is 0.7.2 and other plugins include Glue for Yoast SEO & AMP 0.4.3, Jetpack 6.4.2, Yoast 8.0, Yoast SEO Premium 8.0, Yoast SEO Video 8.0.1 – in case those raise any obvious red flags. (It’s hosted on WPengine).

    Thank you!
    William

  • The topic ‘Missing extensions (youtube, twitter etc.)’ is closed to new replies.