Support » Plugin: WP Custom Admin Interface » Missing ‘Edit Page’ Link in Admin Bar / Toolbar

  • Resolved SimonBVynl

    (@simonbvynl)


    Hi,

    Thank you for the plugin; it’s great. However I am having one issue which I can’t seem to resolve. When logged in to my client’s site myself (as Admin), I can edit a page, view it on the front end, and there I can see a link in the top toolbar to ‘Edit Page’. However, since installing this plugin my other Admin and Editor cannot see this link. It is not even listed in the Admin Toolbar section of the plugin. I have applied Toolbar settings from your plugin to the two people who can’t see the link, but not to myself. I have tried resetting the Toolbar to default WP settings, and they still can’t see the link in the top toolbar to ‘Edit Page’.

    I would very much appreciate your help on this please.

    Thank you

    Simon

    p.s I’ve also noticed one or two small bugs. Let me know if you’d like me to tell you them.

    p.p.s. Here’s my diagnostic info . . .

    PHP Version: 7.0.32
    Wordpress Version: 4.9.8
    Plugin Version: 7.7
    Current Theme: Will4Adventure
    Active Plugins:
    VaultPress
    Admin Bar Edit Content Links
    Cache External Scripts
    Captcha by BestWebSoft
    Custom Facebook Feed Pro – Album
    Custom Facebook Feed Pro Business
    Disable Emojis (GDPR friendly)
    Duplicate Post
    Erident Custom Login and Dashboard
    Google Calendar Events
    Google Remarketing Codes
    Health Check & Troubleshooting
    Instagram Feed
    MailChimp for WordPress
    Pixel Caffeine
    Remove Query Strings From Static Resources
    Simple Login Log
    Simple Page Ordering
    Stream
    Cookie Consent
    Update Theme and Plugins from Zip File
    User Admin Simplifier
    User Role Editor
    W3 Total Cache
    Yoast SEO Premium
    WP Custom Admin Interface
    WP-Optimize
    WP Robots Txt
    WP Social Avatar
    WPForms Lite

Viewing 6 replies - 1 through 6 (of 6 total)
  • p.s. I forgot to say that also the front end Admin Toolbar shows the word ‘Menu’ with no working link, and also if you rollover the name of the site in the Toolbar then it shows ‘Visit Site’, when (whilst you are on the front end) it should actually be showing ‘Dashboard’.

    Plugin Author Northern Beaches Websites

    (@northernbeacheswebsites)

    Hi, this issue has been raised previously in the forum. I don’t have a solution. I suggest not using this particular feature of the plugin if you want specific items on the frontend toolbar. This feature works only for the backend toolbar but it has implications on the frontend toolbar like you have raised. You can also hide these toolbar items with CSS and the plugin provides the ability to add custom CSS very easily. Thank you.

    Thank you. Thing is, even if I now revert to default WP settings in the plugin, then the issue isn’t resolved. Any idea how I can get the ‘Edit Page’ link back please?

    Plugin Author Northern Beaches Websites

    (@northernbeacheswebsites)

    Hi @simonbvynl,

    Have you tried applying the toolbar settings to no-one at the bottom of this settings page? I would be very surprised if this wouldn’t work.

    Thank you. It didn’t work, but I tried reverting again to default WP settings and this time the Edit Page link has returned (although some of the other settings have remained). It seems fine for what I need now, thank you for your help and for the plugin.

    Plugin Author Northern Beaches Websites

    (@northernbeacheswebsites)

    I can confirm that if you set the toolbar to apply to no-one that the default toolbar will show on the frontend and backend of the site. When I said “if you set the toolbar to apply to no-one” do you understand what I mean? Please see the below image: https://www.dropbox.com/s/pp695n7qklexlvl/toolbar.jpg?dl=0

    It sounds like you have it sorted anyway which is good to hear 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Missing ‘Edit Page’ Link in Admin Bar / Toolbar’ is closed to new replies.