User Role Editor
[resolved] Missing Delete Role functionality (5 posts)

  1. Jeshil
    Posted 2 years ago #

    Hi everybody,

    I am using URE 4.9 and it seemed fine, but after upgrading to wordpres 3.8 I had to reassign capabilities to users. Maybe it makes sense, you should always do a back up before upgrading.
    But I created a custom role and I want to delete it, but I am not able to see Delete Role button anymore (I have Add Role, Add/Delete capability)
    The problem is I have to delete that role, because I have done some logic with user roles and it mixes everything up.
    Deleting the role from usermeta table is almost impossible because the capabilities field is so overloaded for a single user.


  2. M
    Posted 2 years ago #

    I've got the same issue...

  3. M
    Posted 2 years ago #

    downgrading to User Role Editor version 4.8 did not help either.

    Has anyone solved it?

  4. Vladimir Garagulya
    Plugin Author

    Posted 2 years ago #


    While role is assigned at least to one user, you can not delete it with User Role Editor. Delete role button is shown in case if there are unused roles, roles which you may delete.
    Go to the users list, check if you have users with that role you wish to delete, and re-assign them the other role 1st.

  5. Jeshil
    Posted 2 years ago #

    Thanks a lot Vladimir, it solved my problem :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • User Role Editor
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic