Support » Fixing WordPress » Missing database tables in a new install

  • After removing varnish from my virtualbox install my wordpress press blog failed to load. So I created a new database ‘wordpress2’ changed the database name in the wp-config and successfully brought up the install.php and got a success page clicked the login button and it said I had one or more databases that needed repair, after adding the repair database code to wp-config.php it said this:

    wp_posts: Table 'wordpress2.wp_posts' doesn't exist
    wp_comments: Table 'wordpress2.wp_comments' doesn't exist
    wp_links: Table 'wordpress2.wp_links' doesn't exist
    wp_options: Table 'wordpress2.wp_options' doesn't exist
    wp_postmeta: Table 'wordpress2.wp_postmeta' doesn't exist
    wp_terms: Table 'wordpress2.wp_terms' doesn't exist
    wp_term_taxonomy: Table 'wordpress2.wp_term_taxonomy' doesn't exist
    wp_term_relationships: Table 'wordpress2.wp_term_relationships' doesn't exist
    wp_commentmeta: Table 'wordpress2.wp_commentmeta' doesn't exist

    Why would a new database give these errors? My working wordpress install was out of the box, no posts or configurations yet, except for multisite.

    confused,
    rad1964

Viewing 5 replies - 1 through 5 (of 5 total)
  • Whats the exact msg you got when you tried to login?

    Remove the repair code and try to repair it from phpmyadmin, although I doubt a new/fresh database needs repair!

    Error establishing a database connection

    I went into phpmyadmin and decided to just delete the database and try again, this time it worked. Why I have no clue 🙁

    Because first time the your database user/pass were wrong 🙂

    Any other issues you need help with?

    HostPuma,
    I added myself to the users and granted myself all privileges, so that was not the reason. As I installed the new database and all was working, I reinstalled Varnish and immediately got the same database error when refreshing my wp-admin: One or more database tables are unavailable. The database may need to be repaired.

    varnish web site docs I followed were simple sudo apt-get install varnish no way to screw that up.

    I am posting similar thread to Varnish forum, just thought there might be someone with some wordpress/varnish experience.

    rad1964

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Missing database tables in a new install’ is closed to new replies.