Support » Fixing WordPress » Missing Dashboard Options and Insufficient Privileges

  • I’m at a total loss here as to what to do. Really frustrating, and been having this problem for quite some time, in one area or another. It first started with upgrades from 1.5 to 2. After the upgrade, the dashboard options were missing and clicking any of the few available links generates an error, “You do not have sufficient permissions to access this page.”

    I found that when this happens after the upgrade, most often I can just remove the cache and things go back to working again. This is not so with my latest problem.

    I’m running 40 or so blogs on an IIS 6 server with php v5.0.4 and mySQL 4.1.14. I decided to move my hosting over to a linux server (bluehost) and have done so; they’re using the same php and mySQL as myself.

    I’ve uploaded my wordpress folders from my own local server to bluehost, using phpadmin to backup and restore each database. Some of these work, others don’t, giving me the above problem. From what I can tell, the databases that work only have one admin account. Those that do not work have two admin accounts.

    Here’s what I’ve tried in resolving the problem, each with a fresh install and a fresh database restore:

    1. Downloading a fresh copy of WordPress, both in zip and in tar.gz. Upping a copy of each, I’ve tried restoring the database – nothing doing.

    2. Removing all plugins, despite their being inactive.

    3. Clearing out the permalinks and active plugings tables before backup and restore.

    4. Using the same WP2 folder, installing a fresh copy of WP into prefix2_ (which works) and then switching back the wp-config.php to prefix1_.

    5. All possible combinatons of clearing the cache, upgrading, logging out etc.

    6. Removing the extra admin accounts – either of them.

    7. Removing the extra admin accounts before backup, restoring with only the one.

    I really, really need some help here. Totally willing to give someone access to whatever they need to help me figure this out.


Viewing 4 replies - 1 through 4 (of 4 total)
  • I should also add that I’ve tried restoring the database using phpadmin, ssh, as well as mysqladmin.

    Also to add, I tried another solution, found here: where one replaces the old wp_usermeta table with a freshly created – this works, although not a feasible solution for 40 weblogs (as it also changes the title, etc.)


    I’ve tried just about everything, short of actually paying someone to fix this problem. I finally found an answer here – kind of a crapp solution to execute on 40 blogs, however it does work. Posted by pjh at this location:

    He says to do the following:

    I had this problem (on WP 2.01) after changing my database prefix from ‘wp_’ to something else. In addition to renaming all of my tables, I had to update entries in both the usermeta and options tables. Here are the statements, assuming that I’ve changed the table prefix from ‘wp_’ to ‘x_’.

    mysql> update x_options set option_name = ‘x_user_roles’ where option_name = ‘wp_user_roles’;
    Query OK, 1 row affected (0.00 sec)

    mysql> update x_usermeta set meta_key = ‘x_capabilities’ where meta_key = ‘wp_capabilities’;
    Query OK, 2 rows affected (0.25 sec)

    mysql> update x_usermeta set meta_key = ‘x_user_level’ where meta_key = ‘wp_user_level’;
    Query OK, 2 rows affected (0.00 sec)

    And this works, after then clearing my cache. I hope it doesn’t cause problems later on and if someone knows more about this than the guy blindly cutting and pasting sql queries into his phpadmin (that would be me), please speak up…..

    Being that I appear to always be the only contributor to my own threads 😉 – I thought I’d post my exact solution for this, rather than the clues I pieced together above.

    1. First I FTP’d over all the appropriate core files
    2. Using phpAdmin, I did a backup and restore of the database to its new location.
    3. Logged in and noticed no dashboard, executed the following SQL query in my phpadmin query box(where XX_ is your own prefix, ‘wp_’)

    update XX_options set option_name = ‘XX_user_roles’ where option_name = ‘XX_user_roles’;
    update XX_usermeta set meta_key = ‘XX_capabilities’ where meta_key = ‘XX_capabilities’;
    update XX_usermeta set meta_key = ‘XX_user_level’ where meta_key = ‘XX_user_level’;

    4. Cleared my cache by removing it from the wp-content folder.

    Now all be well – I just wish I knew what had caused the problem in the beginning.



    did this resolve the problem long term? I’m having a problem where I just see Howdy,. and i don’t have sufficent priviliges in the dashboard to do anything.

    Did running the sql fix the problem long term?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Missing Dashboard Options and Insufficient Privileges’ is closed to new replies.