Support » Fixing WordPress » Missing chinese characters

  • Hi all, I am new to WordPress.
    I have one “Contact Us” page in both English and Chinese simplified version. Everything works fine in English version. However in my Chinese version’s CONTACT PAGE SETTING, i filled-in the content title with Chinese characters and updated. The output of my web page is without the Chinese characters, it is not “???” or “□□□” but just disappear. It is OK if the title is in English alphabets. Any idea on what is going wrong?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Are you theme using cufon or font face etc? They don’t support Chinese characters so nothing will display.

    Ya I am using Felis 1.5 by fireform, it has Cufon and Google fonts.
    Is there any method to continue using this theme by alter the font-family used and switch to other font?

    I was going to say “Yes, ask your government to let Google be and they will be more supportive.” but that is not a good answer that will help…not now anyway.

    A: You can add/change to whatever font family you want in the theme stylesheet. It must be supported natively by the browser in use.

    CSS font-family

    I am not sure whether i am following the correct step. I am updating the stylesheet (style.css) file with the following code:

    h1 {
            font:30px hei,verdana !important;
    	line-height:1.3em
    }

    The only change i can see is the font-size, the font family isn’t change to verdana at all! Besides, when the page is loading, i can see the chinese characters showing up and before the page is completely loaded, the chinese characters are just disappear. In short, the chinese characters shown up 1 or 2 seconds duration only.

    Any idea?

    Hi, Google fonts will not make the Chinese disappear. Cufon will make the Chinese disappear. It seems you are using the cufon option.

    As your theme also support google fonts, please use this option.

    Cufon will draw the characters when loading the page. This is why you can see the Chinese in the first 1 to 2 seconds. After loading and drawing, Chinese is broken. Try google fonts option. Google fonts don’t support Chinese either but at least will not make the Chinese disappear.

    Thanks for the hint, at least I know which part is going wrong.
    May I know how to set the pages to use google font?

    @import url(http://fonts.googleapis.com/css?family=PT+Sans);

    h1 {
            font:30px 'PT Sans',arial,verdana,;
    	line-height:1.3em
    }

    I’ve tried above but not working.

    Hi, where did you put the @import part? It needs to be at the very beginning of style.css, before any css statement starts, or else it won’t work.

    Yes already put them at the very beginning of style.css page.

    Just check at the theme’s key features, it is written there “Cufon and Google fonts (since version 1.6)”, and I am using version 1.5. So i still can use @import part?

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Missing chinese characters’ is closed to new replies.