Support » Plugin: Freesoul Deactivate Plugins » Missing checkboxes?

  • Resolved Iworldc

    (@iworldc)


    Hello,

    I installed the plugin, disabled a bunch of plugins for the home page and it works. However, after coming back to the plugin’s home page settings, I first thought that all settings were gone.

    Then I realized that the row with all checkboxes are simple not showing.

    So I cannot edit further. All I see is the row with plugin names (vertical) and the plug icon. Below that row there WAS a second row with checkboxes. This row is missing now.

    The Archives page has the same problem. No second row.

    The Post Types page looks good. This one does still have the second row.

    The Search page looks completely different. Here it’s not a horizontal table, but a vertical list.

    It would also be great to have a setting to enable or disable the automatic zooming of the table. I have quite some plugins. So the table gets very wide and then compressed horizontally to an almost unreadable narrow format.

    Final question… I used custom URLs to disable plugins in the backend, but that does not seem to work.

    Can you please help me get these things fixed?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Jose

    (@giuse)

    hello @iworldc
    thank you to open the thread.

    First of all, let’s be sure you are not missing anything.

    First I kindly ask you to update the plugin to version 1.6.3, I’ve released few minutes ago. I would like to do problem-solving in the last version.

    The homepage you see in the settings navigation is a shortcut to another settings page that depends on the main WordPress settings in “Settings” => “Reading” where you decide if If your home page is the last blog posts or a static page.

    Due to the fact you have the homepage settings in 2 settings pages, I don’t exclude you have saved the home page settings two times overriding the desired settings.

    Please let me know if what written above could be the issue for the home page.

    Regarding your other issue “So I cannot edit further. All I see is the row with plugin names (vertical) and the plug icon. Below that row there WAS a second row with checkboxes. This row is missing now.

    The Archives page has the same problem. No second row.”,

    Please install the last version 1.6.3. If you still have this issue I will ask you for more details until this problem is solved.

    About the Search settings page “The Search page looks completely different. Here it’s not a horizontal table, but a vertical list.”
    This is because the settings are related only to the search results page, you don’t need anything else than the list of plugins and the opportunity to check and uncheck the plugins. The same for the mobile settings page.
    On other settings page you need a matrix compose by the pages (posts..) and the plugin names.

    About “It would also be great to have a setting to enable or disable the automatic zooming of the table. I have quite some plugins. So the table gets very wide and then compressed horizontally to an almost unreadable narrow format.”.
    Please let me know your screen width in pixels and the number of plugins you have.

    In case you have problems to find your screen width => right click => Inspect Elements => Console and then write window.outerWidth and press enter.

    Custom URLs work only on front-end. The actual version of this plugin doesn’t do anything on back-end. Probably I will add custom URLs for back-end on future versions.

    Iworldc

    (@iworldc)

    Hello Jose,

    Thank you very much for the very detailed and quick answer. I will first install the 1.6.3 version and then come back here…

    • This reply was modified 9 months ago by Iworldc.
    Iworldc

    (@iworldc)

    Hi Jose,

    So I’ve updated to the latest version 1.6.3.

    My Settings -> Reading is set to my latest posts.

    I don’t think that I overrode the settings FOR THE HOME PAGE SETTINGS. It just looked so, because the second table row is not visible. That is the row with the checkboxes.

    So I don’t see what’s checked and what’s not checked. Therefore I mistakenly thought that all settings were gone. That’s not the case. They’re just invisible, because this row with checkboxes is missing.

    Unfortunately the new version did not fix this.

    Please see this screenshot, I just took:
    http://innerworldcreation.com/images/screenshot_1.png

    I tried it on my laptop. This one has a screen resolution of 1366×768. On that screen it’s almost impossible to read the vertical columns, because of the zooming.

    On my PC screen, which is 2560×1080 it’s better, but still not very clear. When I hit F12 in Chrome and set the table zoom level manually to 1.0 it looks much better.

    Then I have to scroll horizontally, but that’s better than looking at the shrunken table.

    I have 67 plugins. Now you understand why I want to disable plugins on certain pages. 🙂

    I would be super nice to have custom URLs for the backend.

    Iworldc

    (@iworldc)

    I also see some errors in the console. Please see this screenshot:
    http://innerworldcreation.com/images/screenshot_3.png

    Plugin Author Jose

    (@giuse)

    Hi @iworldc, thank you very much for the information.

    I would like to focus on one problem, after we solve it we go ahead until we don’t solve all the issues.

    If you agree, let’s first check the missing row on the homepage settings.

    You say that in the main WordPress settings Settings => Reading you have selected your last blog posts.

    Please first confirm you have WordPrss 5.3.2 and you see the same settings as shown in the picture at https://we.tl/t-5oApNPAtpT, I want to be 100% sure because we will do all the problem-solving based on that and I will try to reproduce your case on my installation.
    If you don’t have WordPress 5.3.2, please let me know what version you have.

    If you confirm what written above, please check on the plugin settings page “Archives” and tell me if you see the row “Posts Archive”. When all works right you see that row and the settings of that row are the same as on the settings page “Homepage”. I already know you don’t see them on the settings page “Homepage”, but please let me know what you are seeing on the settings page “Archives”.
    If you see the row “Posts Archive” on the “Archives” settings page, please disable the plugins you want to disable and then click on the eye icon. On the page that opens on the new tab, inspect elements and go to console to see if the disabled plugins are the right ones. You see the disabled plugins in the console only if you came from the link of the eye icon, you will not see them if you visit the page in another way.

    Plugin Author Jose

    (@giuse)

    Hi @iworldc

    please download the beta version 1.6.4 you find at https://downloads.wordpress.org/plugin/freesoul-deactivate-plugins.1.6.4.zip and let me know if you still have issues with the homepage settings.
    I’ve added also a button to activate/deactivate the zoom.

    This version is not public, so you will not find the usual update notice in your plugins page, you need to install it manually.

    If you still have issues with the homepage settings, please read my previous comment and let me know.

    Plugin Author Jose

    (@giuse)

    Hi @iworldc. Now can update it to 1.6.5 directly in your plugins page. Please let me know about the issue of the homepage settings.

    Iworldc

    (@iworldc)

    Hi Jose,

    First I have to say that your support is really awesome.

    I installed version 1.6.5, cleared the Cloudflare cache and voila! That works!

    I now have the second row with checkboxes on the Home Page settings. Fantastic.

    Thank you for getting that fixed. And also a big thank you for adding the zoom button. That is a huge improvement!

    For your information, because you asked for it. I’m still on WP 5.0.3. This is because I have some custom made plugins that are not compatible yet. So I’m always a little behind. For security that’s not a big issue, because I have several firewalls protecting the site. Anyway, your plugin IS backwards compatible with WP 5.0.3.

    The “Posts Archive” and the “Home Page” rows are now indeed both visible and they are the same.

    So as far as I can see is everything working perfectly fine now!

    Thanks again for your outstanding help!

    Plugin Author Jose

    (@giuse)

    Hi @iworldc Perfect. thank you very much for the information, for your words and for giving me the opportunity to improve the plugin.
    I will close the thread. For any other problem don’t hesitate to open a new thread.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Missing checkboxes?’ is closed to new replies.