Support » Plugin: ImageInject » Missing cc icon

  • Hi, I’ve just added to another post about Pixabay images not showing up. I haven’t had a chance yet to disable all other plugins so I can’t narrow down any possible conflicts.

    ***

    The reason I came to the support forum: the cc icon doesn’t appear in posts even though it’s included in my options page.

    I’ve installed the latest version of the plugin, moments ago, and it’s made no difference.

    The attribution template from my options page reads:
    <small>Image credit:{link}{author}{cc_icon}</small>

    The result in the source page reads:
    <small>Image credit: <a href="http://www.flickr.com/photos/53646146@N02/5629358838">Humphrey King</a>, {cc_icon}</small>

    The result on the web page itself reads:
    Image credit: Humphrey King, {cc_icon}

    So the plugin adds a comma and prints out the cc_icon code.

    Also the plugin today has been unable to insert medium or large images, only small. It keeps showing the message ‘Saving all images to your server’ – however when I visit the media library the images have been uploaded, just not inserted in the post.

    I didn’t have any of these problems in the past, I’m not sure when they started. I’ve been using CloudFlare for several months – I don’t think that coincides with the beginning of the problems but I’ll pause it to test it out.

    Any explanations?
    Donald

    https://wordpress.org/plugins/wp-inject/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Thomas Hoefter

    (@thoefter)

    Hi Donald,

    that’s odd. The icon is still parsing fine for me and I dont see why it would stop suddenly.

    Can you please try changing the attribution template to

    <small>Image credit:{link}{author} {cc_icon} </small>

    and see if that makes a difference?

    Hi, I’ve tried that change but it made no difference. However I suspect there may be some javascript conflicts so I’ll check over the next few days and get back to you.
    Thanks,
    Donald

    Hi, again, I haven’t made any progress. I’ve switched off possible javascript conflicts but without any effect.

    Very interestingly, I’ve noticed that posts I made before the problem started still show the cc icon. I don’t know what this means but I know it must mean something…

    The problem will be at my end somewhere – I’ll take another look at caching.
    Donald

    Plugin Author Thomas Hoefter

    (@thoefter)

    Hi Donald,

    I would be surprised if that is related to caching. Did you try just disabling all plugins temporarily? If not that might be worth a shot. As might be deleting and reinstalling WP Inject completely.

    Unfortunately there is not much more advice I could think of. This is an odd issue and I have still not heard of anything similar.

    That’s fine, Thomas, I realise it’s a wierd one. I’ve tried uninstalling but a re-install made no difference. I’ll get round to turning off the other plugins, but that might not be for a while.

    Thanks for your help,
    Donald

    Just a quick note that you can see if CloudFlare is the cause at all by simply pausing us in the settings. Taking a quick look at the domain in your profile, however, doesn’t show any features turned on that might impact this (Rocket Loader could potentially impact if the images rely on JavaScript or jQuery…but I see this turned off).

    Hi, Damon, I don’t think CloudFlare could be the cause, I frequently pause it and I haven’t seen any changes. I’ve turned off Rocket Loader for the time being because of another probem. I suppose I’ve got several things to look at…

    Yeah, that’s not us then. Just wanted to give you a quick tip on how to see if we were the cause or not. Best of luck to you in finding out what the issue is…

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Missing cc icon’ is closed to new replies.