Support » Plugin: Autoptimize » Missing Autoptimize PHP files

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    don’t see any autoptimized resources any more (only WP fastest cache), so guess solved (or a fluke).

    if ever you re-enable autoptimize you could try the new “404 fallback” option, that can help a lot 🙂

    hope this helps,
    frank

    I did change a few settings between this post while troubleshooting gtmextrix & my chrome are still reporting the errors:
    https://gtmetrix.com/reports/www.sociocracyforall.org/DAFaOSeO

    It’s actually 410 errors. Parts of the page show up blank too.
    The files exist in the main folder.

    i’ve tried clearing all caches *except* autoptimize
    I’ve also tried having cloudflare on developer mode and purging cache.

    I do have the 404 fallback enabled

    I wonder if it’s something in my htaccess?

    from the autoptimize chache folder on WPEngine:

    EDIT: this is exactly the same as the one on the host I just switched from. I did just switch hosts, could be related?

    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresByType text/css A30672000
    ExpiresByType text/javascript A30672000
    ExpiresByType application/javascript A30672000
    </IfModule>
    <IfModule mod_headers.c>
    Header append Cache-Control “public, immutable”
    </IfModule>
    <IfModule mod_deflate.c>
    <FilesMatch “\.(js|css)$”>
    SetOutputFilter DEFLATE
    </FilesMatch>
    </IfModule>
    <IfModule mod_authz_core.c>
    <Files *.php>
    Require all granted
    </Files>
    </IfModule>
    <IfModule !mod_authz_core.c>
    <Files *.php>
    Order allow,deny
    Allow from all
    </Files>
    </IfModule>
    ErrorDocument 404 /wp-content/autoptimize_404_handler.php

    • This reply was modified 5 months, 4 weeks ago by supaiku.
    • This reply was modified 5 months, 4 weeks ago by supaiku.
    • This reply was modified 5 months, 4 weeks ago by supaiku.
    • This reply was modified 5 months, 4 weeks ago by supaiku.
    • This reply was modified 5 months, 4 weeks ago by supaiku.

    I kinda need to disable AO to keep the site working decently as things are broken with it enabled now. I would love to fix it though!

    It seems that the “By default files saved are static css/js, uncheck this option if your webserver doesn’t properly handle the compression and expiry.” option was unchecked and that was a problem. Perhaps it was correctly configured on the past server, but not a fit for this new one.

    Thanks for making some awesome plugins! <3

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Afraid I need to see it broken in order to troubleshoot .. :-/

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    but 2 tips;
    1. make sure to disable all/ any JS/ CSS/ HTML options in WP Fastest Cache
    2. re-activate the “serve as static files” option

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    It seems that the “By default files saved are static css/js, uncheck this option if your webserver doesn’t properly handle the compression and expiry.” option was unchecked and that was a problem. Perhaps it was correctly configured on the past server, but not a fit for this new one.

    our replies crossed 😉

    happy it works now supaiku! and great work you’re doing, the world needs more harmonious decision-making. I’ll dive into some of the resources you’re offering!

    in the meanwhile feel free to leave a review of the plugin and support here! 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.