WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Missing argument wpdb: in 3.5 Final

[Resolved] Missing argument wpdb: in 3.5 Final

  • Warning: Missing argument 2 for wpdb::prepare(), called in /home/termopak/domains/przemyslawdurczak.pl/public_html/wp-content/plugins/nextgen-gallery/lib/tags.php on line 319

    Hi, I ‘ve just upgraded to wp 3.5. I have Nextgen 1.9.8 installed and working, however after the upgrade I’ve got this type o error.
    I have no clue what to do, this matter should be already solved (I’ve seen exacly the same error fixed in WP 3.5 RC2), but it didn’t work for me. Do you have any clue what could be the problem?

    Site is: http://www.przemyslawdurczak.pl

    Thx in advance

    http://wordpress.org/extend/plugins/nextgen-gallery/

Viewing 15 replies - 1 through 15 (of 51 total)
  • Error is due to $wpdb::prepare() requiring a second argument. The boards are currently filled with the same exact error.

    Well, I managed to make the warning to go away with the functionality still working.

    I made a change to nextgen-gallery/lib/tags.php by adding ‘null’ as second argument, changing the line

    $term_ids = $wpdb->get_col( $wpdb->prepare("SELECT term_id FROM $wpdb->terms WHERE slug IN ($sluglist) ORDER BY term_id ASC "));

    to

    $term_ids = $wpdb->get_col( $wpdb->prepare("SELECT term_id FROM $wpdb->terms WHERE slug IN ($sluglist) ORDER BY term_id ASC ", null));

    goood is working now , thank you

    I have the same error using the Sharebar plugin. Until the developers update their plugins try this in your function.php

    ini_set( ‘display_errors’, false );
    error_reporting( 0 );

    It stops error mesages and once the plugin devs update- just remove the code.

    Worked over at http://www.outdoorphotography.co.nz/ I hope this helps

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/theloveu/public_html/wp-content/plugins/nextgen-gallery/lib/tags.php on line 318 and defined in /home/theloveu/public_html/wp-includes/wp-db.php on line 990

    I simply installed the NextGen Gallery update from Photocrati today and now have this error at the top of my posts. I’m using the current wp 3.5.

    Could you please fix it? I’m not comfortable creating my own temporary fix.

    I’ve deactivated the plugin until there’s a fix but you are welcome to look at my site anyway:
    http://popcultureplayground.com

    Thank you.

    Because my blog has 5 years worth of NextGen Gallery posts, I followed Ranno’s suggestion. It changed nothing. Thank you, Ranno, anyway.

    I got an error to. Is NExt GEn going to fix this?

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/arrisje/public_html/wp/wp-content/plugins/nextgen-gallery/lib/tags.php on line 318 and defined in /home/arrisje/public_html/wp/wp-includes/wp-db.php on line 990

    here is my site http://arrisje.com

    @Ranno – your fixed worked perfectly for me. Thanks!
    I disabled the plugin, updated the code, re-enabled and no errors.

    My experience – I upgrade three NextGEN Gallery sites to WP 3.5 with no issues. A fourth site displayed errors during WP upgrade due to the legacy ‘p2pConverter’ plugin. After disabling ‘p2pConverter’ I had the NextGEN error discussed here. This would indicate that I was either lucky three times or the NextGEN works with 3.5 but fails in some situations.

    Thanks Ranno…

    Thanks @Ranno, it works fine for me.
    http://www.michalplesnik.sk

    same problem is here http://wallpapers.asf-mobiles.com/wallpaper/92

    plz tell me how to solve this problem

    Thanks Ranno that worked 😀 Love the forums!!!!

    Thanks Ranno!
    It works 🙂

    Ranno, you saved my day !
    Many thanks !!!

Viewing 15 replies - 1 through 15 (of 51 total)
  • The topic ‘[Resolved] Missing argument wpdb: in 3.5 Final’ is closed to new replies.