WordPress.org

Support

Support » Plugins and Hacks » Yoast SEO » Missing argument 3 for wpseo_upgrader_process_complete

Missing argument 3 for wpseo_upgrader_process_complete

Viewing 15 replies - 1 through 15 (of 15 total)
  • WPyogi

    @wpyogi

    Forum Moderator

    Have it too.

    Hello, same here. I noticed this error is shown everytime you upgrade anything.

    Solution status update – FYI:

    I’ve just committed the fix – if anyone prefers not to wait for the next official version, but wants the fix **now* (at your own risk), you can download the current development version of the plugin and upload the unzipped files to your site via FTP.

    I also have the error. Appears on upgrade to anything. I will wait, though, for you folks to thoroughly test. It doesn’t seem to keep upgrades (of anything) from “completing successfully”.

    Ditto here:) Same error appears again after any plugin upgrade.

    @idogenealogy true, it is nothing major and won’t stop anything from working – it’s only the meta description check on theme update which won’t be executed.
    Oh and the fix is thoroughly tested, don’t know the status for any other updates which may be in the dev version.

    Good to know because I have this issue also.

    I guess I am not the only one to see such problem of line number 259. As long as my site is working fine, I will wait for yoast to update the public version and not the development version. 🙂

    Same here with multiple sites I manage after WP upgrade. Everything seems to work OK though. Look forward to fix.

    OMFG! I’m having such problems!

    Even after taking my Prozac! I am still getting the error message!

    Disable v. 1.4.19.
    Upload the Beta.
    Install the upgrade on the Beta!

    TaDa!! No more Prozac!

    @newyorkrobthe issue is solved in 1.4.19, the only time you will still see the message is when you upgrade the WPSEO plugin as at that time you are still using the old version, any new upgrades of themes and plugins (after the WPSEO update) should not give the error message.

    (Edit: made bold for new visitors to this thread to quickly find this answer)

    It seems a lot of people are seeing the same issue. I updated a few days ago, and just updated with their latest version this morning, and again got the error message.

    I’m not sure if this error is affecting my site negatively, doesn’t appear so, but hope the next update fixes this soon.

    Warning: Missing argument 3 for wpseo_upgrader_process_complete() in /home/USERACCOUNT/public_html/wp-content/plugins/wordpress-seo/inc/wpseo-non-ajax-functions.php on line 259

    I got this error on my previous update. I had confidence that it would be fixed shortly, but no, I updated today and see the same error. I have downloaded the latest version to my computer and I will search for the file in question to compare it with what I have installed and if they are different, I plan to replace my screwy file with a new one. I only hope I don’t break something else in the process. Since it took so long to find this particular thread (silly me, I tried the Yoast site first) I was truly expecting to find a fix here and I don’t see one. 🙁
    Edited to add, the new version I got today is 1.4.19

    @dominolady, silly you indeed as only two messages above yours you’ll see that the issue *is* solved and why you still got the warning message when upgrading.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Missing argument 3 for wpseo_upgrader_process_complete’ is closed to new replies.
Skip to toolbar