Support » Plugin: Newsletter » Missing argument 2 for wpdb::prepare() after update to WP 3.5

  • First of all a big thank you for the great plugin – it provides exactly the funcionality I’m looking for.

    Anyway, a small “heads up”: I upgraded to WordPress 3.5 today and while checking all the plugins I found a warning message in the “Subscribers” panel of your plugin. The full error code is

    Warning: Missing argument 2 for wpdb::prepare(), called in <PATH_REMOVED>/wp-content/plugins/newsletter/users/index.php on line 106 and defined in <PATH_REMOVED>/wp-includes/wp-db.php on line 990

    That’s not a real problem, this check has been inserted by the WP-Team to reduce vulnerabilities against SQL injections. The whole story is described in Andrew Nacin’s Blog Post.

    Otherwise I’m very happy with your plugin, thanks so much for providing (and maintaining) it!

    Kind regards,

    McCavity

    http://wordpress.org/extend/plugins/newsletter/

Viewing 1 replies (of 1 total)
  • Plugin Author Stefano Lissa

    (@satollo)

    Hi, I read the note by WordPress team and thank you to find out where the plugin has this problem. I’ll fix asap.

    Stefano Lissa.

Viewing 1 replies (of 1 total)
  • The topic ‘Missing argument 2 for wpdb::prepare() after update to WP 3.5’ is closed to new replies.