WordPress.org

Support

Support » Plugins and Hacks » Dynamic Widgets » [Resolved] Missing argument 2 for wpdb::prepare()

[Resolved] Missing argument 2 for wpdb::prepare()

Viewing 15 replies - 1 through 15 (of 17 total)
  • This can be fixed by searching the file /classes/dynwid_class.php for the string

    prepare($query)

    and replace it with

    prepare($query,null)

    the string should be found twice in that file.

    Thanks a lot, gerobe. Worked like a charm 🙂

    this worked for me.

    replace with

    function prepare( $query = null ) { // ( $query, *$args )
    if ( is_null( $query ) )
    return;

    Plugin Author Qurl

    @qurl

    I thought I already pushed a fix for that to the development version, but looking into it now, that’s apparently not the case. Will do that asap.

    Plugin Author Qurl

    @qurl

    OK, fix is available in the development version.

    I have the same error using the Sharebar plugin. Until the developers update their plugins try this in your function.php

    ini_set( ‘display_errors’, false );
    error_reporting( 0 );

    It stops error mesages and once the plugin devs update- just remove the code.

    Worked over at http://www.outdoorphotography.co.nz/ I hope this helps

    Hello Gerobe, TxAggie08 and Qurl.
    I am asking something rather unorthodox and that is if you guys might be so willing/open/awesome to take a look at my post regarding a rather similar issue with wordpress 3.5. Different plugin, similar problem. I tired messing around with it but had no luck.

    Yes, I know this is a different plugin and this forum is for this plugin.
    However, You guys seem awesome, look like you know your way(s) around plugins and figured I would give this a shot.

    Plugin in question: WordPress Popup
    http://wordpress.org/extend/plugins/wordpress-popup/

    Link:
    http://wordpress.org/support/topic/v-432-spits-out-errors-with-wordpress-35

    Thanks in advance!

    Regards,
    Chevyman

    Hi chevymanusa,
    I have seen, that you already could fix this the same way. Great.

    this is an error i have been having. just hope its going to be updated soon!

    Plugin Author Qurl

    @qurl

    Please see a few posts before, some 12 hours ago. It’s fixed in the latest development version.

    Thanks for the support and pardon the thread jacking.

    You all have a wonderful day!

    Adding “null” to the query solved it nicely for my site.

    I have some problem: Warning: Missing argument 2 for wpdb::prepare(), called in /home/content/82/9592282/html/shop/wp-content/themes/classipress/index.php on line 85 and defined in /home/content/82/9592282/html/shop/wp-includes/wp-db.php on line 990

    I don’t know how to fix it,

    I have same problem: Warning: Missing argument 2 for wpdb::prepare(), called in /home/content/82/9592282/html/shop/wp-content/themes/classipress/index.php on line 85 and defined in /home/content/82/9592282/html/shop/wp-includes/wp-db.php on line 990

    I don’t know how to fix it,

    Plugin Author Qurl

    @qurl

    The warning occurs in the classipress theme. Please contact the author of the classipress theme. This topic is about the same warning in the Dynamic Widgets plugin and has been resolved.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] Missing argument 2 for wpdb::prepare()’ is closed to new replies.
Skip to toolbar