Support » Plugin: Super Progressive Web Apps » Missing Add To Homescreen In PWA

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter Arun Basil Lal

    (@arunbasillal)

    Hey @tanoromero

    Of course we will help!

    Everything looks good: Manifest is added, service worker is in place and registering correctly and your site has HTTPS.

    The only issue that I see is the start_url in the manifest. https://www.tagmas.com/ is redirected to https://www.tagmas.com/publicidad-rosario/

    Go to WordPress Admin > Settings > SuperPWA and set Start Page as: https://www.tagmas.com/publicidad-rosario/ from the drop down if it is present there.

    Save the settings and please try again and let me know how that goes. Looking forward to it.

    tanoromero

    (@tanoromero)

    Hi Arun, tagmas.com it is unavailable now, so i´m testing it in https://opticamarani.com.ar and i have the same problem.
    I am testing with android, but will it work in iOS too?

    morgao

    (@redb68)

    Hi
    Same issue here https://seo.morgao.com
    Everything seems good but don’t work (i’ m on iOS)
    Many thanks for your job

    Thread Starter Arun Basil Lal

    (@arunbasillal)

    Hey @redb68

    iOS doesn’t support PWA’s yet, it only works on Android for now.

    Currently Google Chrome (version 57+), Chrome for Android (62), Mozilla Firefox (57), Firefox for Android (58) are the major browsers that support PWA.

    I see another issue, the start_url is not https, but starts with http instead. If you go to WordPress admin > Settings > General, does the WordPress url start with https? If not, you have to update it there and then deactivate and reactivate SuperPWA (so as to re-generate manifest and service worker).

    Best regards.

    morgao

    (@redb68)

    What is strange is than this plugin works on iOS ! https://fr.wordpress.org/plugins/progressive-web-apps/

    Thread Starter Arun Basil Lal

    (@arunbasillal)

    @redb68 Even offline?

    Thread Starter Arun Basil Lal

    (@arunbasillal)

    @redb68 – Correct me if I am wrong please, but it looks like there is no SSL certificate installed on your server. Maybe its from Cloudflare only?

    tanoromero

    (@tanoromero)

    Hey Arun, Did you get my message with the access?

    Thread Starter Arun Basil Lal

    (@arunbasillal)

    @tanoromero I have received the login, I will look into it and update you soon.

    Thread Starter Arun Basil Lal

    (@arunbasillal)

    This issue was related to how HTTPS was forced using SSL plugins. We have worked together on this over email and it is now fixed.

    The necessary updates will be rolled out to everyone in the next version of SuperPWA, released shortly.

    Thanks for your cooperation @tanoromero. I hope you enjoy your Super Progressive Web App 😉

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @arunbasillal I’ve deleted your offer to login to your user’s site. I’m am 100% sure you mean well but please never ask for credentials on these forums.

    https://wordpress.org/support/guidelines/#the-bad-stuff

    Now for the why: The internet is a wonderful place full of very nice people and a few very bad ones. I’m sure everyone here is very nice however, by giving some ones keys to your house you are trusting they wont steal anything. Likewise the person who takes the keys is now responsible for the house FOREVER.

    If something was to go wrong, then you the author may well legally become liable for damages, which they would not normally have been as their software is provided without warranty.

    Please be aware that repeatedly asking for credentials will result in us asking you to repeatedly stop before escalating up to the plugins team.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Missing Add To Homescreen In PWA’ is closed to new replies.