i’m using the class included in this plugin inside my plugin. We renamed the class to avoid conflicts. What i was wondering is: what is the minum PHP version for this class to work?
When i call
$user = $facebook->getUser();
i always get back nothing on an install with PHP 5.2.17 and if i use firebug to output the instance of the class i get
Facebook_WP_Extend_Ai1ec( kSupportedKeys = Need PHP 5.3 to get value DROP_QUERY_PARAMS = Need PHP 5.3 to get value DOMAIN_MAP = array( ['api'] => 'https://api.facebook.com/' ['api_video'] => 'https://api-video.facebook.com/' ['api_read'] => 'https://api-read.facebook.com/' ['graph'] => 'https://graph.facebook.com/' ['graph_video'] => 'https://graph-video.facebook.com/' ['www'] => 'https://www.facebook.com/' ) appId = xxx appSecret = 'xxx' user = signedRequest = NULL state = '45ccea945634fb4c98335b7dcb9dec96' accessToken = '230498423718200|7a87eb62bb2676da5a6324be0299beb7' fileUploadSupport = FALSE )
which hints to the fact that 5.3 is required. Is it true?On other installs with the same app_id/secret everything is working as expected
- The topic ‘Minum PHP version for using version 1.0 of the class included in this plugin’ is closed to new replies.