Support » Plugin: Plugin Report » Minor WP versions

  • Resolved Ewout

    (@pomegranate)


    The plugin report shows a plugin that shows tested up to 5.5 as incompatible with 5.5.1, yet WordPress ignores this (source):

    Tested up to – The version of WordPress that the plugin has been tested against. This field ignores minor versions, as plugins shouldn’t break with a minor update. This means a plugin only need to define the major version it is tested against and the WordPress.org plugin directory will automatically add the minor version. This should be numbers only, so ‘4.9’ and not ‘WP 4.9’

    I believe this pertains primarily to third party (non WP.org) plugins.

    Can you fix this please?

    • This topic was modified 1 year, 9 months ago by Ewout. Reason: added screenshot
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Roy Tanck

    (@roytanck)

    Thank you for reporting this. The plugin currently interprets WP version number the same way as plugin version numbers. I’ll need to add an exception for WP versions. Will include this in a new version asap.

    Plugin Author Roy Tanck

    (@roytanck)

    @pomegranate Can you point me towards a plugin that exhibits this behavior? I’m having trouble reproducing the issue. Thank you.

    Thread Starter Ewout

    (@pomegranate)

    This was with a plugin that is not hosted on wordpress.org and doesn’t itself have a readme.txt. The updates (and version compatibility information) are passed via EDD‘s plugin updater framework, which is part of their paid Software Licensing extension. Unfortunately I cannot share this, but if you have something for me to test I’d be happy to, just let me know!

    I did see this happening with a wordpress.org plugin too: https://wordpress.org/plugins/code-snippets/
    Shows 5.5.0 in red.

    Plugin Author Roy Tanck

    (@roytanck)

    If you could try this feature branch from Github, that would be wonderful. It appears to fix the issue for the “code-snippets” plugin, and the I’m confident the approach is generic enough to deal with other similar issues as well.

    https://github.com/roytanck/rt-plugin-report/tree/fix/ignore-minor-wp-versions

    Thread Starter Ewout

    (@pomegranate)

    Yes, that works perfectly, great job!

    Plugin Author Roy Tanck

    (@roytanck)

    Thanks for testing! I’ll merge this into a new version later this week.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Minor WP versions’ is closed to new replies.