Support » Plugin: Visual Link Preview » Minor Bug Fixes

  • Thank you for this great plug-in, it’s really useful.
    BTW, I’ve found 2 minor issues.

    1.
    If the summary has a link tag which is not closed in the summary, it will cause to the next part, so I’ve fixed 54 line of class-vlp-link.php as below.

    
    # $properties['summary'] = nl2br( trim(             $unsanitized->summary   ) );
      $properties['summary'] = nl2br( trim( strip_tags( $unsanitized->summary ) ) ); 
    

    2.
    When it crawls YouTube link, it shows summary as “Sorry for the interruption. We have been receiving a large number of requests from your network.”.
    Different with the above issue, I couldn’t spend time for check this is my IP problem or this plugin’s structure problem.

    I hope this can be an info for the other useres.

    • This topic was modified 9 months, 1 week ago by jaycasee.
    • This topic was modified 9 months, 1 week ago by jaycasee.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Brecht

    (@brechtvds)

    Happy to hear you’re enjoying the plugin and thanks for the feedback!

    1. I’ll do some testing for the summary. I do want to allow HTML tags in general as those can be used to make stylistic changes (bold, italic, underline, …).

    2. I just tested a YouTube link on my site and it loads things there. The plugin makes use of the Microlink API, so maybe that one had been sending too many requests to YT?

    Plugin Author Brecht

    (@brechtvds)

    Hi again,

    I wanted to let you know we just released Visual Link Preview 2.2.0 which should fix the summary problem you mentioned. Thanks for letting me know!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Minor Bug Fixes’ is closed to new replies.