Support » Plugin: Credit Line Generator » Minimum WordPress version and Visual Editor support

  • Plugin Author hatesspam

    (@hatesspam)


    Hi, it is the author here.

    I have added functionality that will now also let you use the Credit Line form in the Visual editor instead of just the Text editor.

    In order to do this, I had to increase the minimal WordPress version from 3.3 to 3.9. This is a WordPress version that was introduced 5 years ago, so in theory this should harm no-one.

    If for some reason you still use older versions of WordPress, older versions of this plug-in should work just fine with your WordPress installation.

    My main reason for adding support for the Visual Editor is so that people who install the plug-in without reading the manual, won’t go “it doesn’t work!” when they try to find a button in the Visual Editor.

    As a result there is at least one minor bug in the Visual Editor version where after generating a credit line, the cursor jumps to the first link in your post. This is such a minor problem that I thought it would be more beneficial to publish this upgrade with it than to try and fix the bug first.

    If you see anything else going wrong, as always, please post it here.

    I have been working on a Gutenberg version of the plug-in, but that appears to be more problematic than I initially imagined (mostly because I have to refactor basically everything), so the next feature you might see turn up is probably going to be some form of translatable strings instead.

Viewing 1 replies (of 1 total)
  • Plugin Author hatesspam

    (@hatesspam)

    To be clear, plugin versions starting with 3.0 require at least WordPress 3.9; version 2.0 of the plugin should work with WordPress 3.3 and newer.

Viewing 1 replies (of 1 total)
  • The topic ‘Minimum WordPress version and Visual Editor support’ is closed to new replies.