Support » Installing WordPress » Minimum setup to install WordPress ?

  • wolfneo

    (@noaneo)


    Hi,
    On the page,
    https://codex.wordpress.org/FAQ_Installation
    We can read this

    MySQL or MariaDB[edit]
    Do I really need MySQL/MariaDB?[edit]
    You certainly need the MySQL or MariaDB database servers to power your WordPress blog. In fact, WordPress only supports the MySQL and MariaDB database servers. Listed are the PHP and MySQL/MariaDB requirements:

    WordPress server requirements for Version 3.2+:
    PHP version 5.2.4 or greater
    MySQL version 5.0.15 or greater or any version of MariaDB
    (Optional) (Required for Multisite) Apache mod_rewrite module (for clean URIs known as Permalinks)

    Is this always the minimum setup to install WordPress?
    Or is the page not up to date?
    Thank you

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Steve Stern

    (@sterndata)

    Support Volunteer

    That’s the minimum for core, but it’s not really going to work, as many plugins now require PHP 5.6 or 7.x, and themes are following along. You also need a version of MySQL that supports multibyte strings.

    For a secure and fast site, you should be using the latest versions of both PHP and MariaDB.

    wolfneo

    (@noaneo)

    Hi,
    Thank you for your reply.
    I explain, I indicated, by mistake, on a forum that the minimum configuration was the one indicated there
    https://wordpress.org/about/requirements/
    and kindly, one person told me the other link and especially the part I put in my previous post.
    Honestly, I find the other configuration, obsolete.
    PHP version 5.2.4 or greater
    MySQL version 5.0.15 or greater

    Do not update the page So?

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.