Support » Plugin: Author Avatars List » Minimum posts setting takes no effect

  • Resolved netzgestaltung

    (@netzgestaltung)


    Hi, when i set “Required minimum number of posts” to “1” and save, the Athors with zero posts are still shown.

    when i var_dump $instance, then $instance[‘display’][‘min_post_count’] is string(“”)

    but the widget form displays “1” after saving.

    what couldt have gone wrong?

    https://wordpress.org/plugins/author-avatars/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Paul Bearne

    (@pbearne)

    I don’t know

    But it sounds like I need to look

    did you create the shortcode with the wizard to make sure it correct?

    Paul

    i use the widget.

    i tested it now with the shortcode wizard:

    [authoravatars roles=administrator,editor,author,contributor hiddenusers=1 user_link=authorpage display=show_name,show_postcount,show_last_post min_post_count=1 order=display_name,asc]

    and it works – it only does not for the widget

    as a workarround i can add shortcode execution to widgets an add the shortcode to a text widget, but thats not what its supposed to (i think)

    as i played arround with the widget also the black and white list options seem to do nothing

    Plugin Author Paul Bearne

    (@pbearne)

    thanks for the testing

    sounds like the widget has got out sync with the shortcode I will fix ASP

    revert my previuos post

    somehow its fixed. as i reopened the widgets page today all widget settings where gone and when i set all of them again it just works. dont know why.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.