Support » Plugin: Cue by AudioTheme.com » Minifying JS Breaks Cue plugin

  • Resolved chris.vandeviver

    (@chrisvandeviver)


    Hello,

    I recently bought WP Rocket for caching, and it has the option to Minify JS. However, I notice when I enable JS minification, it breaks Cue. The result is a playlist without any buttons, header, or navigation.

    WP Rocket allows me to exclude certain JS properties from minification. Can anyone help me figure out how to exclude Cue?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Brady Vercher

    (@bradyvercher)

    Hi Chris,

    I’m not familiar with WP Rocket, but they do have some documentation for excluding scripts from being minified. For what it’s worth the scripts in Cue are already minified, so there shouldn’t be any need to minify them again.

    Cheers,
    Brady

    Thanks for the quick response.

    That’s actually what I’m trying to do – not minify Cue. Can you help me identify the script I would need to exclude?

    Plugin Author Brady Vercher

    (@bradyvercher)

    If you can share the URL for your website, that would help, but if you replace the domain in the following URL with your own, this is the typical location of the main Cue script: https://example.com/wp-content/plugins/cue/assets/js/cue.min.js

    Thanks so much!

    The domain is https://thebrasspalace.com.

    You can view the player specifically on https://thebrasspalace.com/portfolio.

    Do I need to specify specific pages, or the root address is usable?

    Unfortunately though I exclude the script, WP Rocket still breaks the players. I’ll approach them about the issue. Thank you!

    Plugin Author Brady Vercher

    (@bradyvercher)

    The script is always available at the URL I sent and doesn’t change per page, so using the root address should be all that’s needed.

    The player appears to be working correctly for me. Have you tried clearing your browser cache or viewing that page in a private window?

    Yes, I tested it with a private Firefox window. I enabled the JS minifying and disabled it almost immediately, haha. That would be why you see it’s working.

    Wanted to follow up:

    I don’t what the difference is yesterday from when I began this thread, but I once again used the following code in the JS Exclude field in the Advanced settings in WP Rocket:

    https://example.com/wp-content/plugins/cue/assets/js/cue.min.js

    The result worked! Maybe I left out a character the first time?

    Either way, thanks for the help!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.