Support » Plugin: W3 Total Cache » Minify URL rewriting test fails – ModRewrite works

  • Hello everybody!

    I have some error message on the admin Minify page that I have ignored until now, but I hope it might be the reason why minification does not work for me with both CSS and JS (until now, I accepted jQuery-dependent JS and CSS could just not be merged and minified).

    So, W3 Total Cache complains to me:

    .htaccess file contains rules to rewrite url http://www.mydomain.de/wordpress/wp-content/cache/minify/000000/w3tc_rewrite_test. If handled by plugin, it returns "OK" message.
    The plugin made a request to http://www.mydomain.de/wordpress/wp-content/cache/minify/000000/w3tc_rewrite_test but received:
    500 Internal Server Error
    instead of "OK" response.

    In /html/wordpress/wp-content/cache/minify/.htaccess I have the following line (I attach the entire document below):

    RewriteRule /w3tc_rewrite_test$ ../../plugins/w3-total-cache/pub/minify.php?w3tc_rewrite_test=1 [L]

    What bothers me: the 000000 from the tested URL does exist in the file structure. However, it does not exist in the .htaccess. Might this be part of the problem?

    Thank you for any hints in the right direction.

    Ah, and of course the most obvious:
    According to this instruction here (german, but probably easy to understand) my Rewrite Engine works properly. Also, it is activated in the host’s backend.

    The website can be reached at team-ev.de if that helps.

    Error message complete

    W3 Total Cache error:It appears Minify URL rewriting is not working. Please verify that the server configuration allows .htaccess
    Unfortunately minification will not function without custom rewrite rules. Please ask your server administrator for assistance. Also refer to the install page for the rules for your server.
    Technical info

    .htaccess file contains rules to rewrite url http://www.mydomain.de/wordpress/wp-content/cache/minify/000000/w3tc_rewrite_test. If handled by plugin, it returns "OK" message.
    The plugin made a request to http://www.mydomain.de/wordpress/wp-content/cache/minify/000000/w3tc_rewrite_test but received:
    500 Internal Server Error
    instead of "OK" response.

    .htaccess complete

    # BEGIN W3TC Minify cache
    Options -MultiViews
    FileETag MTime Size
    <IfModule mod_mime.c>
        AddEncoding gzip .gzip
        <Files *.css.gzip>
            ForceType text/css
        </Files>
        <Files *.js.gzip>
            ForceType application/x-javascript
        </Files>
    </IfModule>
    <IfModule mod_deflate.c>
        <IfModule mod_setenvif.c>
            SetEnvIfNoCase Request_URI \.gzip$ no-gzip
        </IfModule>
    </IfModule>
    <IfModule mod_headers.c>
        Header set X-Powered-By "W3 Total Cache/0.9.4"
        Header set Vary "Accept-Encoding"
    </IfModule>
    # END W3TC Minify cache
    # BEGIN W3TC Minify core
    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /wordpress/wp-content/cache/minify/
        RewriteRule /w3tc_rewrite_test$ ../../plugins/w3-total-cache/pub/minify.php?w3tc_rewrite_test=1 [L]
        RewriteCond %{HTTP:Accept-Encoding} gzip
        RewriteRule .* - [E=APPEND_EXT:.gzip]
        RewriteCond %{REQUEST_FILENAME}%{ENV:APPEND_EXT} -f
        RewriteRule (.*) $1%{ENV:APPEND_EXT} [L]
        RewriteRule ^(.+/[X]+\.css)$ ../../plugins/w3-total-cache/pub/minify.php?test_file=$1 [L]
        RewriteRule ^(.+\.(css|js))$ ../../plugins/w3-total-cache/pub/minify.php?file=$1 [L]
    </IfModule>
    # END W3TC Minify core

    https://wordpress.org/plugins/w3-total-cache/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Some progress:

    If I strip Options -MultiViews from the .htaccess, I do not get the error anymore.

    Same isssue here, the Options -MultiViews does not help. Googled a lot, still no idea, what could be wrong.

    I’ve got the same problem but instead of “500 Internal Server Error” I receive 404 Not Found

    I’m not surprised test received 404 error because in fact, no 000000 directory exists in my l/wp-content/cache/minify/ directory, hence there is no w3tc_rewrite_test file.

    All settings are as recommended. Cache directory and subdirectories chmod is 755

    I wonder why? What is wrong?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Minify URL rewriting test fails – ModRewrite works’ is closed to new replies.