Support » Plugin: W3 Total Cache » Minify CSS / JS works but doesn’t remove original files

  • Resolved blackhill24

    (@jonnorman43)


    Hi,

    Im having an issue with W3 minify, it is set up manually and to all intents and purposes works fine apart from the original files that get combines and minified are still being loaded.

    I tried to diagnose the problem this afternoon on my WAMP set up and everything works as expected, I then tried copying all setting from my local setup to my live setup and the problem came back.

    I don’t think we’re using any plugins that should cause an issue apart from SG Optimizer but with this, I have completely disabled the cache in the siteground dashboard and removed the plugin but the issue still persists?

    I can provide a list of plugins but basically, this includes Woocommerce and a few supporting plugins.

    I have also tried updating the plugin (not the functions.php) from this link, which made no difference – https://wpml.org/errata/w3tc-is-not-minifying-files/

    If I need to provide any more info please ask.

    Thanks
    Jon

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,
    Can you give an example of the files that are still being loaded?

    yes. here they are…

    /wp-content/plugins/woocommerce-composite-products/assets/css/frontend/woocommerce.css
    /wp-content/plugins/woocommerce-product-addons/assets/css/frontend.css
    /wp-includes/css/dashicons.min.css
    /wp-content/themes/my-theme/assets/css/font-awesome.min.css
    /wp-content/uploads/responsive-menu/css/responsive-menu-1.css
    /wp-content/plugins/popover/inc/external/wpmu-lib/css/animate.3.min.css

    /wp-content/themes/fx-theme/assets/js/jquery.modal.min.js
    /wp-content/themes/fx-theme/library/js/libs/modernizr.custom.min.js
    /wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js

    There are a few more but its quite a long list 🙂

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello,

    You can Try Manual JS minify “combine only” Non-block using async. For CSS, tick “line break removal” and “Process” for @inport handling.
    It’s best to use our help Wizard on top of the Performance>Minify page. Manual Minify can be a very tricky process as the files need to be added in order.
    Also please share your website URL if convenient.

    Hi @vmarko

    Im already using the manual configuration and when testing locally was able to achieve the correct order or js files.

    I will try using async and your other suggestions and see where I get to,

    Cheers

    Ivan Nozhka

    (@nozhko-i)

    Hello @vmarko,

    I’ve got the same issue for multi-site installation. Custom minify works fine for main site, but doesn’t work for each subsite. Actually, minify css is created, but links to original css files are still there.

    blackhill24

    (@jonnorman43)

    That’s interesting, our site used to be multi site but we migrated back to a single installation sometime ago.

    Also, please could this not be marked as resolved as it clearly isn’t?

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.