W3 Total Cache
[resolved] minify and opcode cache causing white screen front end (4 posts)

  1. Nic Windley
    Posted 2 years ago #

    After some debugging I found two offending plugins. The one had to be completely disabled and the other was the opcode and minify settings in W3 Total Cache.

    I've got APC installed and no matter if I selected disk or APC I get a white screen on the front end.

    Same with Minifiy if I enable it. Once disabled output returns to normal.

    I am able to install and enable Tribe Object Cache and use that as well as other minify plugins ?


  2. Nic Windley
    Posted 2 years ago #

    Apologies. This has been caused by improper nginx config.

  3. Newfound
    Posted 2 years ago #

    How did you go about solving this issue? Having a similar problem. Thanks!

  4. Nic Windley
    Posted 2 years ago #

    I disabled opcode cache in W3TC and kept Minify and enabled Tribe Object Cache for opcode caching. This seems to work fine.

    For the dynamic stuff I'm using mfunc with the correct syntax and all is well and working.

    Non dynamic pages get fully cached into static pages while dynamic pages get PHP caching and opcode cache does the rest.

    I've kep nginx out of the equation for now (its running, just not doing much), and I'll be sorting that out at some point to server static content and offload PHP stuff to PHP-FPM to improve the dynamic stuff further.

    Most pages seems to serve pretty quickly: http://www.giftsandmerchandise.co.uk/

    Check your other plugins are not causing any conflicts also.

    Hope that helps.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic