Support » Plugin: W3 Total Cache » Minify and MultiViews

  • Hello,

    I’m happy with using W3TC, but have some troubles with minify functionality. When I first time turn it on, all created files opened with 500 errors, error log is here:

    [Tue Mar 12 00:19:11 2013] [alert] [client 2.95.121.125] /var/www/site1/wp-content/cache/minify/.htaccess: Option MultiViews not allowed here, referer: …

    If comment line Options -MultiViews» in wp-content/cache/minify/.htaccess files shows okay until cached files were purged, but new files weren’t created.

    I’ve added to secure.conf these lines:

    <Directory "/var/www/site1/wp-content/cache/minify/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>

    and whatever MultiViews are commented in .htaccess or not minified files are not creates (404 error) and nothing in server error’s log is presented.

    Please, help!

    http://wordpress.org/extend/plugins/w3-total-cache/

Viewing 3 replies - 1 through 3 (of 3 total)
  • I’m having the same issue since a recent w3 total cache update. I have to manually comment out the Options -MultiViews line every time I change some settings in the wp-admin. Not exactly ideal and it seems weird I can’t find much info on this topic anywhere.

    I have the same problem, this is a quick fix to solve this until the developers create a more user-friendly way (created by diff, which is commonly used for creating patches):

    --- MinifyAdminEnvironment.old.php      2013-08-09 15:09:10.442893335 +0200
    +++ MinifyAdminEnvironment.php  2013-08-09 15:08:57.342893564 +0200
    @@ -533,7 +533,9 @@
    
             $rules = '';
             $rules .= W3TC_MARKER_BEGIN_MINIFY_CACHE . "\n";
    -        $rules .= "Options -MultiViews\n";
    +        if (!defined('CUSTOM_W3TC_DISABLE_MULTIVIEWS') || !CUSTOM_W3TC_DISABLE_MULTIVIEWS) {
    +            $rules .= "Options -MultiViews\n";
    +        }
    
             if ($etag) {
                 $rules .= "FileETag MTime Size\n";

    The file resides in w3-total-cache/lib/W3
    If you add define(‘CUSTOM_W3TC_DISABLE_MULTIVIEWS’, true); to your wp-config.php, then it should work.

    I had to add MultiViews to my vhost AllowOverride to get it working.

    AllowOverride AuthConfig FileInfo Indexes Limit Options=All,MultiViews

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Minify and MultiViews’ is closed to new replies.