Support » Plugin: LiteSpeed Cache » Minify and combine results in longer page loads

  • Resolved dpacks

    (@dpacks)


    I am fiddling with a huge theme which results in pages bigger than 4MB in size.

    The problem is that if I use the Optimize feature in LSCache with minify and combine, the resulting CSS and JS files are large uncompressed files. Google complains about this wildly and gives the site a low (red) score.

    If I disable the Optimize feature altogether in LSC and install W3TotalCache alongside LSCache and enable Browser cache in it (which adds gzip compression to served files), I get better loading times and a good (green) score in Google (without using the minify and combine option in this plugin either).

    I’m using the CDN option in LSC with 6 subdomains mirroring the main domain which keeps the unminified, unmerged css and js files at a reasonamble loading rate, which pleases google slightly.

    Below are my settings:
    https://imgur.com/a/ScQvT

    And here is what google tells me:
    https://imgur.com/a/6Kd91

    To recap: the problem is that the files optimized by LSC are being served uncompressed and there is no option to control compression.

Viewing 1 replies (of 1 total)
  • Hello,

    If you are system administrator go to litespeed webadmin -> Configuration -> Server -> Tuning -> GZIP Compression. There is a limit for Max Static File Size (bytes) and rise it.

    If you are not the system administrator … contact your hosting provider.

Viewing 1 replies (of 1 total)
  • The topic ‘Minify and combine results in longer page loads’ is closed to new replies.