Support » Plugin: W3 Total Cache » Minification Manual mode 403 errors

  • Resolved disturbed-pixel

    (@disturbed-pixel)


    Hi,

    I need to control the order of the scripts to ensure jQuery and a couple of other files are loaded first, so i need to use Manual minification.

    if i turn on General settings -> “Minify mode” to Manual i get a load of 403 errors on each of the Javascripts.

    Request URL: https://xxxxx.stackpathcdn.com/staging-three/wp-content/cache/minify/0/f7cfe.default.include.13cca9.js
    Request Method: GET
    Status Code: 403 

    f7cfe is the folder
    default.include.13cca9.js is the filename of the script

    When i go to the folder “/cache/minify/0/f7cfe” (on the server) that should contain this javascript there is a file in there (default.include.13cca9.id) with an .id extension that contains a short serialise string with a alphanumeric value.

    Is it supposed to behave like this? Where is the javascript?

    Please advise
    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @disturbed-pixel

    I am sorry about the issue you are experiencing and I am happy to assist you with this. Manual Minify can be very tricky.
    I suggest that you disable minify, manually delete wp-content/cache/minify/ folder and purge CDN
    After that, you can start from scratch.
    Make sure to add JS and CSS files in proper order and in the correct Template.

    Hi Marko,

    I followed your instructions, disabled minify, manual deletion and cdn purge and started from scratch, the issue persists. (i have included the files in to the ALL templates group)

    I have only been trying to manually minify/combine two scripts only as a test run, basically wordpress jquery and jquery migrate.

    every time i get a 403, as i in that folder path there are .id files created. (screenshots below)

    in the folder above, i can see the full css file but no Js.

    Thanks

    https://snipboard.io/OPqdoF.jpg

    https://snipboard.io/OPqdoF.jpg

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @disturbed-pixel

    YOu should disable CDN to limit possible sources of the problem.
    403 means this URL blocked. So you check the .htaccess if there’s something that blocks access to /cache folder.
    Usually its some security plugin.
    Thanks!

    Hey Marko,

    I have been investigating since my last post and have talked with the CDN company and the hosting company. It looks like two rules (advanced character string filters) created by the All in One Security plugin are the cause.

    RedirectMatch 403 \.inc
    RedirectMatch 403 include\.

    Soon as i comment these out, it works perfectly! I did not think that those two rules would cause so many problems.

    Sorry for wasting your time.

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.