Support » Plugin: WooCommerce » Mijireh Slurp Page meta box not showing up on Mijireh Secure Checkout page

Viewing 15 replies - 1 through 15 (of 16 total)
  • vtex


    I get the same issue, were you able to find the solution?



    Here is what someone from Mijireh responded with:

    Sometimes certain web hosts are not set up to allow page slurp to work. When that happens you will need to slurp the page from inside your Mijireh account.

    First, make sure the page you are trying to slurp is publicly available on the internet. You may need to change the status from private to public.

    Next, log into your Mijireh account and go to Settings => Checkout Page (top right of screen)

    In the “Select your e-commerce platform” drop down choose “custom”

    Enter the URL to the page you are going to slurp and click the “Slurp It” button.

    Then you will see a progress bar appear showing the status of your page slurp.

    If you have any other questions, please let me know.

    -Benjamin Rojas
    Mijireh Support



    Thanks that worked!

    I tried that, but then the integration between woocommerce and mijireh no longer worked. When I clicked “check out” it took me to Mijireh, but said my cart was empty. Any ideas of what happened there?

    @hannahhill – I’m having the same problem now. Did you find a solution?

    @HannaHill & @sherriev – Having the exact same problem with my site. Did you guys have any luck finding a solution?

    @johnludena – Actually, I did! If you read the directions, it talks about a “Mijireh Private Checkout” page being created. Its not your checkout page that is normal – its looking for another one! So, make a page, and add the {{mj-checkout-form}}, Slurp that NEW page, and voila.. It will work.

    The whole problem was that the page that was supposed to be created, wasn’t being created.

    @sherriev You are freakin’ awesome. That was exactly it. For some reason I didn’t have that special Mijireh checkout page already created in my template, so I just went ahead and created it using the shortcode and voila! Worked perfectly.

    I love WordPress, WooCommerce & Mijireh. Match made in eCommerce heaven!

    You’re welcome! I’m glad it worked for you too. I was ripping my hair out over here trying to get a handle on what was wrong.

    I did leave an update on my ticket to mijireh, so hopefully the issue gets addressed.


    You are awesome! Thanks for providing the way to fix the “empty cart” issue faster than the Mijireh response team….still waiting.

    The Accidental Winery

    It worked for me, too… but I realized I had to force the HTML by inputting the code above {{mj-checkout-form}}, but within code tags. Once I did that, and saved the page, the Slurp It! option came up at the bottom and all is now well!

    Make sure you do this in the text editor.
    < code> {{mj-checkout-form}} < /code>

    *make sure you remove the spaces in the code tags.

    Worked for me too. The problem happened when I un-installed and re-installed woo commerce. The Mijireh page was missing. Created new page called Mijireh Secure Checkout and inserted JPC’s code [above] then saved the page. The blue “Mijireh page slurp” box appeared when the page reloaded.

    Anynone having trouble with the textare where you put your name and card info not being big enough to see what you are writing?

    I am using the shortcode in the page – [checkout_mijireh] – that was originally entered from cart66 NOT the {{mj-checkout-form}} above as this did not work, yet I can not get the cart to “connect” to the secure checkout on Mijireh. It has the form for collecting the address on my site but when it supposed to make the connection to Mijireh’s servers, it’s not passing the information and coming up with an empty cart (the slurped page template) on Mijireh’s site. Any ideas what might be going on ?

    I’m still having issues with this. Maybe I’m missing some vital step. Here’s the background/steps so far:

    I have a Mijireh Secure Checkout page in WordPress (which is defaulted to private when I installed Woocommerce)
    I have {{mj-checkout-form}} loaded on the page.
    I also have a checkout page i.e.: that has this on it. [woocommerce_checkout].
    I’m attempting to do a page slurp.
    I go to Woo Commerce > Settings > Gateway > Mijireh but there is no banner prompting Page Slurp.

    Reading the above tips in this thread, log into Mijireh account and go to Settings => Checkout Page.
    I “Select your e-commerce platform” drop down choose “custom”

    Entered the URL to the page you are going to slurp (I’m assuming this is my and click the “Slurp It” button.
    I get an error message saying the slurp has failed. Tips on the page say:

    “Make sure your checkout page’s HTML contains the {{mj-checkout-form}} placeholder token so we know where to inject the checkout form into your design. NOTE: This may already be taken care of for you if you use a plugin or other integration designed for Mijireh Checkout.”

    I go back to the page.
    Do I add this in {{mj-checkout-form}} as well as [woocommerce_checkout]? Not sure. Hoping someone can shed any light.


Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Mijireh Slurp Page meta box not showing up on Mijireh Secure Checkout page’ is closed to new replies.