WordPress.org

Forums

WooCommerce - excelling eCommerce
Mijireh Secure Checkout & WC Checkout problems set up (7 posts)

  1. backfromthedead
    Member
    Posted 1 year ago #

    Having problems with my WC secure credit card checkout since the 2.1 upgrade.

    Website http://www.dimensions-displays.com/shop/

    Its possibly down to my ignorance of how the new endpoints are set up correctly but I can't find any help online.

    Previously in WC2.0 I had Mijireh and Stripe set up and working to process payments so we were PCI compliant.

    I can't figure out how to replicate the set up in WC2.1.

    What page / where do you insert {{mj-checkout-form}} so you can create a secure checkout page on to the Mijireh servers? How do you link the WC checkout and cart to this page. Tried setting up pages with endpoints and "slurping" these but it hasn't worked.

    Tried inserting it on the WooCommerce checkout page. If i slurp this page and then try to place an order and pay with credit card it returns a cart is empty page.

    Does this payment method wotk now in WC2.1 work or do i have to go down the SSL route and buy the Stripe payment gateway plugin?

    https://wordpress.org/plugins/woocommerce/

  2. gypzy
    Member
    Posted 1 year ago #

    I am having the same problem of not being able to direct the checkout to this Mijireh checkout page.

    Did you ever find a solution?

  3. backfromthedead
    Member
    Posted 1 year ago #

    no, got a pretty useless response from woo. ended up buying A SSL certificate and the stripe payment gateway plug-in to fix the problem. This works a lot better. you can get the stripe plug in without a serial code from other venders for $10- google it - and a SSL certificate will vary, mine cost £40 from my webhost.

  4. backfromthedead
    Member
    Posted 1 year ago #


  5. gypzy
    Member
    Posted 1 year ago #

    Thanks for the feedback. I am not using Stripe though. I will have to see if I can find one for TransFirst. Thanks again.

  6. gershuin19
    Member
    Posted 1 year ago #

    Hi gypzy, I'm also using TranFirst, did you found a way?
    Thanks in advance!

  7. gypzy
    Member
    Posted 1 year ago #

    Hi Gershuin19,

    I fixed the issue I was having of the theme not loading the checkout button by increasing the the memory limit. (I had the actual Mijireh page set up fine).

    Adding the following string to wp-config.php file:
    define('WP_MEMORY_LIMIT', '128M');

    (inserted it right below define('WPLANG', '').

    Once I resolved that issue, then I ran into a different issue getting error when trying to place an oder. It looks like it is triggered by charging shipping. I made it free shipping and it seems to work. However, I need to charge for shipping so again, that didn't really fix much. I have an open ticket with WooTheme about the issue. they talked to the developer and it looks like I ca now charge flat rate shipping with out the error. I still need to connect UPS shipping, so fingers crossed i don't run into any more issues.

    Good luck!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic