Support » Plugin: MailPoet - emails and newsletters in WordPress » Migration tool not working

  • Resolved ChrisL

    (@chrslcy)


    Oh dear, oh dear. I’m sorry that your rollout of MailPoet 3 hasn’t quite gone as you would have liked.

    It certainly hasn’t worked for me – but I’m not going to run off and write a horrible review like those petulant sponges who demand everything to be five-star AND FREE!

    Anyway, I upgraded one site without any problems. However, when I tried to do the same on another very similarly configured site on the same server with the same browser, the problems began.

    Firstly, the ‘Start Upgrade’ button did nothing when clicked. So I copied the console log (pasted below). After a while of trying, I opted to go straight to the Settings to try to Install from Scratch, however, only the tabs were visible on the Settings page, with no settings content below.

    Do you think you can help? I’m very happy to provide more information if you need it.

    Many thanks,

    Chris

    MailPoet Version 3.4.4
    WordPress Version 4.9.4
    PHP Version 5.6.33 (with PDO, PDO_MYSQL, XML and ZIP)

    CONSOLE LOG:

    admin.php?page=mailpoet-migration&mailpoet_redirect=https%3A%2F%2FDOMAIN_REMOVED%2Fwp-admin%2Fadmin.php%3Fpage%3Dmailpoet-newsletters:181 Uncaught ReferenceError: ZeroClipboard is not defined
        at HTMLDocument.<anonymous> (admin.php?page=mailpoet-migration&mailpoet_redirect=https%3A%2F%2FDOMAIN_REMOVED%2Fwp-admin%2Fadmin.php%3Fpage%3Dmailpoet-newsletters:181)
        at i (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=4.9.4:2)
        at Object.fireWith [as resolveWith] (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=4.9.4:2)
        at Function.ready (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=4.9.4:2)
        at HTMLDocument.K (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=4.9.4:2)
    (anonymous) @ admin.php?page=mailpoet-migration&mailpoet_redirect=https%3A%2F%2FDOMAIN_REMOVED%2Fwp-admin%2Fadmin.php%3Fpage%3Dmailpoet-newsletters:181
    i @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=4.9.4:2
    fireWith @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=4.9.4:2
    ready @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=4.9.4:2
    K @ load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=4.9.4:2
    load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,svg-painter,heartbeat,wp-auth-check,jquery-ui-core,jquery-ui-widget,jquery-ui-progressbar&ver=4.9.4:246 Uncaught TypeError: Cannot read property 'hasClass' of undefined
        at HTMLDocument.<anonymous> (load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,svg-painter,heartbeat,wp-auth-check,jquery-ui-core,jquery-ui-widget,jquery-ui-progressbar&ver=4.9.4:246)
        at HTMLDocument.dispatch (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=4.9.4:3)
        at HTMLDocument.r.handle (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=4.9.4:3)
        at Object.trigger (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=4.9.4:3)
        at Object.a.event.trigger (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=4.9.4:9)
        at HTMLDocument.<anonymous> (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=4.9.4:3)
        at Function.each (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=4.9.4:2)
        at a.fn.init.each (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=4.9.4:2)
        at a.fn.init.trigger (load-scripts.php?c=1&load[]=jquery-core,jquery-migrate,utils&ver=4.9.4:3)
        at Object.<anonymous> (load-scripts.php?c=1&load[]=hoverIntent,common,admin-bar,svg-painter,heartbeat,wp-auth-check,jquery-ui-core,jquery-ui-widget,jquery-ui-progressbar&ver=4.9.4:245)
Viewing 3 replies - 1 through 3 (of 3 total)
  • Jack K

    (@jack-kitterhing)

    Hey Chris!

    Sorry to see the issues you’ve had on that. Based on your error log output above, there’s a JS error that is preventing the migration tool from working.

    Have you run through troubleshooting, such as disabling all other WP plugins on the site to see if it’ll work correctly then? As it worked on one site in the same environment, my belief would be that another plugin is causing a conflict in the wp-admin.

    Thanks!

    Hi Jack,

    Yes, I tried disabling plugins, incognito mode and a different browser. Really not sure what the issue was but glad to report that I tried again yesterday and was able to migrate without problem. Mystery.

    Very happy with the upgrade. The cron functionality of the new version appears to be far more reliable and consistent and the email content builder is slick.

    Five stars. Thanks.

    Chris

    Jack K

    (@jack-kitterhing)

    Thanks for the update Chris! Glad to hear everything is now working and pleased to hear you like the new version. 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Migration tool not working’ is closed to new replies.