Support » Plugins and Hacks » Migration – Settings not working

Migration – Settings not working

  • Hello,

    I’m NOT new with gantry and today I was going from one environment to another (as usual). All the times I use “WP Migrate DB” or “All-in-One WP Migration” and they worked as expected.

    But with the latest version of gantry I can’t do a successful export from my database.

    So I tried with all this methods and I can’t get the gantry setting from the overrydes or default setings:

    1. “All-in-One WP Migration”
    2. “WP Migrate DB”
    3. “Gantry Export and Import Options”
    4. I tried to fix the sql by hand
    5. I Deleted all the transients (before/after or/and after/before) without success

    So how do you export your gantry sites ?
    Have you read the serialized objects on the gantry wp_options (they are insane)?

    Any input, idea, solution ?



Viewing 2 replies - 1 through 2 (of 2 total)
  • So gantry is loading almost everything as expected :

    • rt_gantry_wp-template-options-override-assignments-xxx
    • rt_gantry_wp-template-options-override-sidebar-xxx
    • rt_gantry_wp-template-options-override-widgets-xxx

    But gantry is not loading :

    • rt_gantry_wp-template-options
    • rt_gantry_wp-template-options-override-xxx

    So example.dev is loading rt_gantry_wp-template-options and creating the correct _transient_GantryAdmin-4.1.1-gantry
    While example.com is NOT loading rt_gantry_wp-template-options and instead I have the default gantry configuration with an extra transient. So at the end I have _transient_Gantry-gantry and _transient_GantryAdmin-4.1.1-gantry

    Well I kind of found a dirty work around… with this method I’m still loosing some serialized data (data from another plugin but with less options to fix).

    So I did a dump of the original database.
    Then in notepad++ I replaced :
    http://example.dev –> http://example.com
    Then again replace from :
    /srv/dev/www/example.dev –> /srv/prod/www/example.com
    And finally :
    example.dev –> example.com

    Now your dump.sql is ready for the new server.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Migration – Settings not working’ is closed to new replies.