Support » Installing WordPress » MIgration issue (old server, new server, same hostname.domain)

  • Resolved Crucis


    I’ve had a self-hosted wordpress blog running for six months. Last summer I moved from blogspot. All worked well (old server: Linux-Fedora 7, Apache 2.2, wordpress 3.4.2) I had a number of services running on that box, MySQL, Apache, sendmail. It’d been running for serveral years but it was slowing down as I put more and more on it.

    I bought a new quad-core (Intel) server, 6BM memory, 1tb RAID1 server and loaded it with CentOS 6.3. I’ve migrated most of the of the webserver contents from the old to the new. I followed the migration instructions in the codex. I was able to backup the wordpress database and restore it on the new box.

    WordPress isn’t running correctly. I can access the initial web page but it’s text only no graphics. I can’t access the administrator pages, dashboard. I get a 404 error. The directory permissions are the same, wp_config.php is the same (no changes required,) owner/group/permissions on the directories and files are the same.

    The only difference is the root directory. Due to space issues, the parent wordpress directory on the old server was/is under root. On the new CentOS box, it’s under /opt. Apache on Centos is httpd-2.2.15-15.el6.centos.1.x86_64, vs. httpd-2.2.8-1.fc7 on the old server.

    I think it’s either a permissions issue or redirection in Apache but I’m a loss to tell which or if it’s something else. At the moment, I’m still pointing at the old box ( I can reroute to the new server if I know in advance when someone would like to look.

    Any suggestions?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hey my problem is that i had a blog on blogger with this domain name Yesterday i shifted to wordpress with hosting with the same domain. I had updated the nameservers on godaddy and i was able to open my website through wifi connection. But, when i used cellular connection,then i was getting an error message this blog was not found on server that’s all we know with google symbol. I thought that this might be because i have not removed the older @ and cname settings for blogger which i have not removed from godaddy. So i deleted them, but its more than 5 hours.Now there is no error message from google, it doesnot even opens any page. Kindly help.

    i think there is an issue with Source Path.
    Can you Give us the link so that we can see what is missing?

    which source path…plz help

    Mark this as RESOLVED.

    From the symptoms, it problem had to be an Apache error. The Apache config files weren’t all that different. I had copied httpd.conf from the old server to the new one. Everything else worked…except for the virtual servers (I have two.) I forgot to check the other hosted domain and didn’t notice it didn’t work until this morning.

    The fix: Instead of copying the “old” httpd.conf and making the changes to reflect the new server, I went back to the original, supplied httpd.conf installed on the new server and modified it to reflect the needs for the webserver.

    Instead of doing a cut ‘n paste for the virtual server section, I re-ented them by hand. This time, the blog looks and appears as it should…

    The problem was Apache and the configuration. The old vs. new server were “nearly” the same version but not exact. Lessons learned: don’t copy config files. Modify the new ones to reflect the correct configuration. Old does not equal the same in the case of config files.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘MIgration issue (old server, new server, same hostname.domain)’ is closed to new replies.