Migration from Windows to ubuntu (3 posts)

  1. agoubar
    Posted 1 year ago #

    Hi team,
    I am really new to ubuntu, but I start bit be comfortable with.

    I did export my database using dos command after looking for good solution without errors; this is from windows to ubuntu server
    here is the cmd command on windows

    C:\wamp\bin\mysql\mysql5.5.8\bin\mysqldump -uroot -p dbname > c:\path\dbname.sql
    this was done without error after the password prompt, ALL fine
    Now I
    I did ftp my wp-content.zip from windows to ubuntu
    then execute the cmd
    sudo unzip wp-content.zip -d /var/www/engtme

    I did change the
    # README.Debian.gz

    NameVirtualHost *:80
    Listen 81

    on the ports.conf file because
    listen 80 was not Unable to connectin the first place
    this was fixed
    Now with port listen set to 81
    I am getting
    Not Found

    The requested URL /engtme/wp-admin/login.php was not found on this server.
    Apache/2.2.22 (Ubuntu) Server at Port 81
    I need really to show something soon and having the prod moving to ubuntu

    Thank you YALL,

  2. JumboClicks
    Posted 1 year ago #

    hope you got this figured out

    first thing i would do is see if you can access a text or image file normally

    I suspect your use of alternative ports is causing you problems

    If this is localhost for design not deployment you should figure out whats running on port 80 and maybe kill it

  3. agoubar
    Posted 1 year ago #

    Thank you for your response.
    I purge my lamp , and remove it
    do the reinstall from the begining
    I have working fine,
    Error establishing a database connection

    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at This could mean your host's database server is down.

    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?

    I have all set


    mypassword is the new password that I created for my database on ubuntu ,so the windows password was blank

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'wordpress');

    /** MySQL database username */
    define('DB_USER', 'root');

    /** MySQL database password */
    define('DB_PASSWORD', 'mypassword');/** mypassword is the new password that I created for my data base on ubuntu the wondos pwd was blank

    /** MySQL hostname */
    define('DB_HOST', '');

    export was fine , and my www folder exported fully to the same directory on the /var/www

    Thank you,

Topic Closed

This topic has been closed to new replies.

About this Topic