Support » Plugin: qTranslate X » migration from mqtranslate to qtranslate-X – step-by-step instruction

  • First of all, thank you John for your plugin and your professional support.

    I’ve completed the migration from mqtranslate (which is no longer supported by the plugin author) to qtranslate-X today and wrote down a simple step-by-step-instruction (in English and German). I hope it may be useful to some of you:

    First backup your homepage (Erstelle zuerst ein Backup deiner Seite).
    1) Install the plugin qtranslate-X (Installiere das Plugin qtranslate-X)
    2) Enable qtranslate-X. Do not worry about the “Warning: Activation of plugin qtranslate-X deactivated plugin mqtranslate since they cannot run simultaneously…”. Just confirm and go ahead (Aktiviere das eben installierte Plugin qtranslate-X. Es erscheint eine Warnmeldung, welche darauf hinweist, dass mqtranslate deaktiviert wird, da nicht beide Plugins parallel laufen können usw. Einfach bestätigen und weiter.)
    3) Select settings – languages in the dashboard and then click on “Import/Export” (Im Dashboard auf Einstellungen – Sprachen gehen und dann “Import/Export” anklicken.)
    4) Select the option “Import settings from mqtranslate” and click on “Save settings” (“Import settings from mqtranslate” auswählen und mittels Schaltfläche “Einstellungen speichern” abspeichern.)

    Although the language selection – widget still worked, I changed it with the “qtranslate Language Chooser” (Der Sprachen-Selektor von mqtranslate schien zwar noch zu funktionieren, aber ich habe ihn sicherheitshalber mit dem “qtranslate Language Chooser” ersetzt:
    From the dashboard select Design – Widgets and select the widget “qtranslate Language Chooser”. Place it whereever you want (in my case in the header of the theme).
    (Vom Dashboard aus, wähle Design – Widgets und wähle das Widget “language chooser of mqtranslate” und platziere es an gewünschten Stelle (in meinem Fall im Kopf des Theme).

    The only problem I had, was a fatal error due to a few code snippets where I used the function qtrans_getLanguage. I modified them, by replacing qtrans_getLanguage with qtransf_getLanguage.
    After having them replaced John Clause, the plugin-author of qtranslate-X adverted me that there would have been another option without touching any code (https://wordpress.org/support/topic/migration-from-mqtranslate-fatal-error-in-code-snippets-plugin?replies=7):
    From the dashboard, select languages and “Advanced settings”, scroll down the page to “Compatibility Functions”. There just select the option “enable functions name compatibility” and save the new setting.
    (Das einzige Problem, welches ich hatte, war ein “fatal error” einiger Codeschnitzel, welche noch die Funktion qtrans_getLanguage beinhalteten. Ich habe die genannte Funktion durch qtransf_getLanguage ersetzt.
    Nachdem ich diese Anpassung gemacht hatte, hat mich John Clause auf den Umstand hingewiesen, dass es unter den “Erweiterten Einstellungen” von qtranslate-X die Möglichkeit gibt, die Option “enable functions name compatibility” einzustellen (https://wordpress.org/support/topic/migration-from-mqtranslate-fatal-error-in-code-snippets-plugin?replies=7). Dann funktioniert es auch.)

    …and don’t forget…after some time, when you’re sure that everything works, you should delete the no longer needed mqtranslate.
    (…und vergiss nicht…nach einiger Zeit, sobald du sicher bist, dass alles passt, solltest du das alte plugin mqtranslate löschen.)

    https://wordpress.org/plugins/qtranslate-x/

Viewing 15 replies - 1 through 15 (of 38 total)
  • Plugin Author John Clause

    (@johnclause)

    Thank you very much, @uobet.

    There is a little typo I spotted:

    replacing qtrans_getLanguage with qtransf_getLanguage

    should be:

    replacing qtrans_getLanguage with qtranxf_getLanguage

    I really appreciate your help.

    Thank you very much, I’ll try to migrate asap.

    Antonio

    Followed all steps – imported mqtranslate settings, checked off “Advanced settings” – “Compatibility Functions”.

    I clear the site’s cache and then, my site won’t load. Completely blank…

    Quite odd. I moved from qTranslate to mQtranslate without any issue last year.

    Plugin Author John Clause

    (@johnclause)

    I am sorry to hear about your trouble, @ricomtl, it sounds terrible. I currently have no clue on what the problem might be. There are about 3-4 reports of real troubles like yours out of about 500 people so far. So something indeed odd happened at your server. Look in the error_log, there must be some message there, can you copy it here? Actually it would be better if you open a new thread for your case specifically, since this topic is not designed for troubleshooting specific cases.

    Will do… the error console is blank, it’s strange. Perhaps it’s a plugin conflict, but I have over 51 plugins active! 🙂

    Thks.

    thank you John, of course it should be qtranxf_getLanguage
    sorry for that

    as to ricontl, I have more than thirty plugins activated but as far a I can say everything is running smoothly.
    I hope that John will be able to help you.

    S

    Same problem here. Blank page after updating from mqtranslate to qtranslate X.

    My Apache error log gives me a PHP Error.:

    PHP Fatal Error: Call to undefined function qtrans_converturl() in /var/www/Username/wp-content/themes/customblue-twentyten/header.php on line 63

    Hi John

    I have mqtranslate on my site. I tried to update to qtranslate-X but had to come back to mqtranslate…

    Actually mqtranslate was compatible with Transposh (which I use to translate some texts in Widgets that mqtranslate can’t translate, and also to add machine translation for extra languages that I do not translate myself). To select language I even use the Transposh widget instead of the mqtranslate widget and it works! See it on http://2cvolive.fr (site in construction, not many translations yet).

    It appears that qtranslate-x is not compatible with transposh. If I use both, either with the qtranslate-x or transposh select language widget, I can’t access to the default language homepage (French) as it get stocked on EN page. Also it adds strange termination like “http://2cvolive.fr/en/es/ if I choose Spanish in the transposh widget, for example.

    Do you have any idea on how to make qtranslate-x and transposh compatible, like mqtranslate and transposh are?

    Thanks.

    Plugin Author John Clause

    (@johnclause)

    Inspite of many successes reported, this plugin is not yet completely really ready to accept all former mq users. The mq author decided to accelerate the process, so we will have to deal with the problems in a rush now. Most of problems are already known and we are working on them. Please, hold on angry and low reviews based on incompatibility with mq.

    Hm, would have been nice to have the deprecated warning at a point when the plugin would be really ready for a clean migration. But it’s how it is. Don’t rush too much. To get it to work is more important than any rush ^^

    Mh, is my problem a known one? Can i assist with something? More information needed?

    Plugin Author Gunu

    (@grafcom)

    Backup, does anyone know yet what this means?

    John take it as you are!

    At step 3 is better you add select the same languages you have in mq and click saving settings, then select import from mqTranslate and save settings again. Otherwise nothing happen and you will have 3 default languages English German Chinese.

    Besides, if someone encounter the same problem of me that tags and categories are not translate do not panic. Access your MySql database and make a search using the query qtranslate_term_name in wp_options and usually has to appear 2 results. You will see the mqtranslate contains the whole terms while the qtranslate is empty and show a:0:{}
    Well, the empirical solution is click modify the mq line copy all terms and then go to qtranslate and paste the terms. It will work.

    It’s a bit strange that import from mqTranslate doesn’t work complete automatically but at least this workaround can help.

    At this time, the import settings function is not working. A fix has been submitted to John but it is not yet in the current released version of the plugin.

    So it’s perfect using both the above instructions and my little contribute it could be possible to fix the issue of tag/category if it happens.

    Hey Guys,
    i followed instructions but i got this problem.
    This is the original with mqTranslate activated.

    When i deactivate both of them my website is as on first picture.
    So basically website is broken without mqTranslate.

    I reactivated mqTranslate and everything works, but i would like to get the newer version.

    Thanks for the answer. (i’m not a programer so please use simple language :))

    P.S.
    If the solution is complicated i could ask my hosting provider to fix it for me. I would need instructions.

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘migration from mqtranslate to qtranslate-X – step-by-step instruction’ is closed to new replies.